Trouble inserting Javascript

Hello. I’m trying to insert some JavaScript code generated by Email Protector; unfortunately, the site that makes it seems to be down at the moment so I can’t link to it, but an example can be found on an old (very plain and simple) site of mine,
http://www.thecoffeefaq.com/
Look at the “click here to email me” link in the italicized text. What the JavaScript does is to create an on-the-fly decrypted email link–not easily read by spambots, but easily used to create a mailto link.

I’ve taken the javascript and pasted it into a Markup Item, but Freeway pastes it on the page as-is (you see the script on the resultant page, not the encrypted link it’s supposed to make).

How can I get this script into a Freeway project?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Scott,
Place your cursor where you want to insert the e-mail link in your run of text and select the Insert/Markup Item menu item. Paste your code in the resulting dialog and click the OK button.
Regards,
Tim.

On 28 Apr 2008, at 19:33, Scott wrote:

I’ve taken the javascript and pasted it into a Markup Item, but Freeway pastes it on the page as-is (you see the script on the resultant page, not the encrypted link it’s supposed to make).

How can I get this script into a Freeway project?

FreewayActions.com - Freeware and shareware actions for Freeway Express & Pro.

Protect your mailto links from being harvested by spambots with Anti Spam.
Only available at FreewayActions.com

http://www.freewayactions.com

Note: Any markup info is going to need to be properly formatted and have the appropriate tags. In your case, something like (I had to add some spaces to get the text to show in the message, it is only for illustrative purposes):

< script type=“text/javascript” > MARKUP GOES HERE < / script >

If you perhaps were just pasting in:

…document.write(…);…

FW treats markup stuff as plain text that it should not modify in any way, and dutifully inserts anything there as you have written as-is.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 29 Apr. 2008, 4:42 am, Tim Plumb wrote:

Hi Scott,
Place your cursor where you want to insert the e-mail link in your
run of text and select the Insert/Markup Item menu item. Paste your
code in the resulting dialog and click the OK button.
Regards,
Tim.

In my original post, I’d said that I’d used a Markup Item, but the code is simply stuck onto the page as plain text. If you’re suggesting doing something differently, I’m not getting it.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 29 Apr. 2008, 12:50 pm, Weaver wrote:

Note: Any markup info is going to need to be properly formatted and have the appropriate tags. In your case, something like (I had to add some spaces to get the text to show in the message, it is only for illustrative purposes):

< script type=“text/javascript” > MARKUP GOES HERE < / script >

If you perhaps were just pasting in:

…document.write(…);…

FW treats markup stuff as plain text that it should not modify in any way, and dutifully inserts anything there as you have written as-is.

Weaver,
The code I was trying is virtually identical to the page I referenced (a page I put together in Dreamweaver), just with a different email address. The code I inserted into the Markup item begins:

< script type = ‘text / javascript’>

(spaces similarly inserted). But Freeway is simply treating it as text.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Can you post a link to the page in question?

Walter

On Apr 29, 2008, at 10:25 AM, Scott wrote:

On 29 Apr. 2008, 12:50 pm, Weaver wrote:

Note: Any markup info is going to need to be properly formatted
and have the appropriate tags. In your case, something like (I
had to add some spaces to get the text to show in the message, it
is only for illustrative purposes):

< script type=“text/javascript” > MARKUP GOES HERE < / script >

If you perhaps were just pasting in:

…document.write(…);…

FW treats markup stuff as plain text that it should not modify in
any way, and dutifully inserts anything there as you have written
as-is.

Weaver,
The code I was trying is virtually identical to the page I
referenced (a page I put together in Dreamweaver), just with a
different email address. The code I inserted into the Markup item
begins:

< script type = ‘text / javascript’>

(spaces similarly inserted). But Freeway is simply treating it as
text.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options