Upload Problems

I’m really fed up. I’m using Freeway4Express 4.4. and EVERY time I update my site I cannot just upload it and go! I have to spend ages trying to tweak to see what I’ve done wrong.

*This time new photos on my Gallery and More pages haven’t uploaded.

*Two old photos on Gallery are messed up

*I did Pic to New Window on all of them but the new views can’t be found (they’re in Site Folder> Media file > Sweater Pics)

*I changed my email link at the bottom of each page back to the original but they are all screwed up too.

*One email field has an extra phone number - don’t know where it came from.

*I have ‘YarnNeedlesEmail’ in blue at the bottom of some pages and I have no idea where they came from either!!!

I can’t afford to spend more time twiddling with this and my clients are looking at this in it’s mucked up state.

Please help!

CarolynMB


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

In case looking at my site helps:

Thanks, CarolynMB


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Ok, after having a look at your site I can see the problem with the gallery. Although your photos are in the Resource photo, the links are not pointing at them. For example, the line for Chuck is looking at http://www.barnett-knits.com/Resources/chuck.jpeg, but in reality the file name is chuck’B.jpg so the file name does not match. Going through and checking your links for the correct file names should fix this.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 26 Nov 2007, at 19:50, chuckamuck wrote:

in reality the file name is chuck’B.jpg so the file name does not
match. Going through and checking your links for the correct file
names should fix this.

If the file name includes an apostrophe, which is not a “legal” HTML
character, then that is probably why the links are broken.

Check through your site and amend the file names for images to not
include apostrophes and & type characters.

(This is Freeway trying to be helpful by using the actual local file
name as the basis for the Alt tag and other bits and pieces.)

Then try uploading again - you might need to visit the server with
an FTP application and delete everything so Freeway has a clear run
at it.

Hope that helps.

Heather


“Freeway - Web Design for All”


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

There are typical culprits for ‘oddities’ like this:
-Actions
-Master Pages/Items (although these will typically show in the FW design view)
-Manual changes/Markup items/etc…

Are you manually doing anything to the pages? Manually adding html code or something like that? Actions do no provide any feedback to the user in the design window, so all may seem well. For instance: Source Code Snooper, although an invaluable tool, sometimes slips by undetected on a page or item and can cause some weirdness later if you forget about it being applied to something.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Chuckamuck, Heather and Weaver, Thanks. I will try these things.
I am not manually coding as I don’t know how (hence using FW) but I have been putting in apostrophes and will clean that up. I will go over my links to the in the Pic to New Window action I’m trying to accomplish too.

I can use Transmit to clear out ‘their stuff’ and re upload ‘my stuff’.

I’ll keep you posted. I gotta get this thing down as I love keeping my site up to date and don’t have the time to fiddle around each time I upload a new change.

CarolynMB


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If you are using an ftp client then uploading the contents of your
Resources folder will probably correct the broken image links. Freeway
has a habit of changing image names when it thinks it should! I have
had this problem many times, if going back to a site made on an
earlier date and adding a new page or other alteration, FW decides for
some reason that it should add an a or b or whatever to some images
names… even if no editing of images has been done.

Hope this helps

On Nov 26, 2007, at 9:23 PM, CarolynMB wrote:

I can use Transmit to clear out ‘their stuff’ and re upload ‘my
stuff’.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 26/11/07 (at 21:30 +0100) Mike B said:

If you are using an ftp client then uploading the contents of your
Resources folder will probably correct the broken image links. Freeway
has a habit of changing image names when it thinks it should!

Actually, this isn’t really the best approach, as Freeway will then
see all those images as things to replace the next time around.

The advice to use Transmit (or any other FTP client) to clear out
files and then do a ‘clean’ upload from Freeway is generally best, as
this allows Freeway to carry on with its general file management -
which normally works pretty well - but clears out the things that are
probably causing problems.

But yep, it is best to clean up the file names of all original source
media - the files put into layouts - so that apostrophese aren’t
included in the output names. This won’t worry all servers, but it
will mess up on some.

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Ok, did the clean upload and stuff has uploaded but still screwy! Went through all my photos ( I think) and made them lower case and no apostrophes. Funny, the email link at the bottom of the pages is one I gave up on (a gif) and went back to just HTML field but I got the gif and not the new html!!!

Also, a big thing I find is that when I upload from Freeway often nothing changes so I have to use Transmit.

Any further thoughts will be greatly appreciated.

Thanks, CarolynMB


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Carolyn - this is a snippet of code from your gallery page

‘Resources/‘Chuck’B.jpg’,‘ChuckB’,‘width=400,height=600,toolbar=no,location=no,scrollbars=no,resizable=no’);return false">Chuck<’);
document.write(’/a>’);

As you can probably see there are still apostrophes in there.

I know you changed the names of your picture files to remove them but after that did you update your resources?

Edit menu>resources and check the status there.

You may have to use the Update all button down the bottom left if the status is not showing as OK. Then reupload.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks all anyway, I’ll try what David says tomorrow.

I’ve been working on and off all day and evening taking apostrophe’s and capitals out of all the files, correcting from my pages to make sure all the photos are copacetic as regards their links. Same with my email addy at the bottom of each page. I deleted what I could find that might be left in the files and sneak onto my site but the still show up.

I completely cleaned out my server and reinserted all files one by one…result? No change. Photos missing and so on. I don’t know how it can draw from old info when I’ve deleted and trashed old info!

Now I’m really fed up! Whew!

CarolynMB


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On Nov 28, 2007, at 5:49 AM, CarolynMB wrote:

I’ve been working on and off all day and evening taking apostrophe’s
and capitals out of all the files, correcting from my pages to make
sure all the photos are copacetic as regards their links. Same with
my email addy at the bottom of each page. I deleted what I could
find that might be left in the files and sneak onto my site but the
still show up.

Clear the browser cache might help, but your site could be cached by
your ISP which might take a few hours before it clears, there are
tricks you can play but I don’t want to complicate things.

I completely cleaned out my server and reinserted all files one by
one…result? No change. Photos missing and so on.

If you are using an ftp client you do not need to upload 1 by 1, just
drag the whole folder contents over (Depending on the ftp program you
can even upload several folders at a time). Also, are you uploading
your images from the Freeway Resources folder or the folder where you
have the originals? it needs to be the contents that Freeway outputs
as it will change the names of some if not many of your images, if you
upload original images you will probably have issues where they cannot
be found.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Carolyn it is not just within Freeway that you need to remove apostrophes, quote marks etc.

Do you have a media folder where you store all your graphics abd photos because it is here that it is important to check.

Usually I have a folder that contains the whole project in your case something like barnettknit.

Within that I have subfolders for media (pictures, graphics, movies etc.), freeway docs, word or text docs and the site folder.

If you organise your files like that then you always know where to find things rather than have everything scattered about your hard drive.

Then go into the media folder and check all your file names for those characters that are screwing things up.

Once you are sure that they are OK then within Freeway go to Edit>Resources and check the status of all the files there.

At this point you will probably have to edit the resources so that they are pointing to your now renamed files in the media folder.

In the Edit Resources window - Hilight the file - click the edit button and then click Locate to find the renamed file in the media folder. (You will also be able to see in here if there are still any odd characters left)

Once again check the status of your resources - are they all saying OK?

Once you have done all that you are ready to republish and upload with Freeway. Just double check in Freeway that your upload path is correct.

File>Document Setup>Upload and check that you have the correct directory set.

By all means clear out the server with Transmit or similar first, but for straightforward uploading Freeway does a great job and keeps track of things much better than you having to remember what you uploaded with Transmit.

Give it a go - have patience and once you are on the right track things will be easy from then on.

And if you need one of the guys to have a look inside your server to check things out for you then I am sure you will find somebody willing to help.

But don’t post any server access info here contact somebody offlist with details.

ATB David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Apostrophes are such a known no no in enough instances that Softpress really
ought to at least warn if using them or disallow altogether - as in
disallowed characters in style names.

If not - why not?
(That is a real question)

all the best
Brian

CarolynMB said recently:

I’ve been working on and off all day and evening taking apostrophe’s and
capitals


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Carolyn,

When you preview the site in a browser from Freeway are the images
working? How are you uploading? If it isn’t through Freeway then try
it, this will upload everything that it needs to whereas uploading
through third party FTP apps can lead to problems such as this.

If you re having problems uploading through Freeway then make sure you
try with Passive FTP Mode turned on and if it fails try again with it
turned off. If it still fails then get in touch with support on email@hidden
and we can help you out.

I’m not sure that the apostrophe’s are the main cause of the problem
but you should still omit them from your image file names. It is the
images being used in the Pic to New Window Actions that you will need
to change the names of, change these in the Finder (your media
folder?) and, as Simon mentioned previously, not in the Resources
folder.

Cheers,

Joe

On 28 Nov 2007, at 04:49, CarolynMB wrote:

Thanks all anyway, I’ll try what David says tomorrow.

I’ve been working on and off all day and evening taking apostrophe’s
and capitals out of all the files, correcting from my pages to make
sure all the photos are copacetic as regards their links. Same with
my email addy at the bottom of each page. I deleted what I could
find that might be left in the files and sneak onto my site but the
still show up.

I completely cleaned out my server and reinserted all files one by
one…result? No change. Photos missing and so on. I don’t know
how it can draw from old info when I’ve deleted and trashed old info!

Now I’m really fed up! Whew!

CarolynMB


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 29 Nov 2007, at 09:24, Joe Billings wrote:

I’m not sure that the apostrophe’s are the main cause of the problem
but you should still omit them from your image file names.

You should also omit them from the word ‘apostrophes’ :slight_smile:

best wishes

Paul Bradforth

http://www.paulbradforth.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

:wink:

On 29 Nov 2007, at 10:14, Paul Bradforth wrote:

On 29 Nov 2007, at 09:24, Joe Billings wrote:

I’m not sure that the apostrophe’s are the main cause of the problem
but you should still omit them from your image file names.

You should also omit them from the word ‘apostrophes’ :slight_smile:

best wishes

Paul Bradforth

http://www.paulbradforth.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options