Validation Fail

I have just uploaded my site and ran the Validate HTML tool within Firefox and it returned a load of errors (34)…
http://www.meteoralimited.com/

Other pages in the site report back wierd body tag errors…
http://www.meteoralimited.com/gumtargets/campaign.html

Has anyone got a free minute to take a look and see if there’s something I can do to clean it up - other sites I have done in a smiliar way don’t report back these errors - the body error is an odd one.

Nathan Garner
Creative Director

Austin Wells Design Limited
One Elmgate Drive - Littledown - Bournemouth BH7 7EF
t 01202 301271 e email@hidden w http://www.austinwellsdesign.co.uk

Member of NAPP


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You might want to check your line of text to see if there’s a markup item or something in there in the FW document. It seems to be dropping in some code snippet stuff and you may have to go to the spot where the error is and simply delete and retype the what you deleted (should be easy to do) and see if that gets rid of it.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

When I looked now, the errors have been reduced to 3.
I discovered something strange in the source sode, :

.... neglect or draining a council<body>'</body>s budget)..... 
' should not be there.

freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I have seen this sort of thing happen before. It’s a Freeway bug, in
my opinion.

What will happen is you style the body tag to have paragraph or text
properties (which is a fine idea to set some defaults). Then you make
an ad-hoc style change somewhere in your document (using the Inspector
to change some property of a single character or a paragraph of text).
As soon as you finish your style changes, Freeway does its normal
styles cleanup, which is to find any available style in the list that
is precisely the same as that combination of attributes that you set
and apply that style instead of making up a new one. In the case of
the body tag, this ends you up with a nested body inside the one and
only body.

Walter

On Jan 10, 2010, at 6:13 AM, atelier wrote:

When I looked now, the errors have been reduced to 3.
I discovered something strange in the source sode, :

.... neglect or draining a council<body>'</body>s budget).....
' should not be there.

freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I’ve seen this happen too. If it is a FW bug has it been reported to SoftPress.

Marcel


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you all, I will go back in and re-do a couple of areas (cleaning it up if required) and see if that clears it.

If it is a bug, I will report it - if not I will report myself!

Thanks again.

Nathan Garner
Creative Director

Austin Wells Design Limited
One Elmgate Drive - Littledown - Bournemouth BH7 7EF
t 01202 301271 e email@hidden w http://www.austinwellsdesign.co.uk

Member of NAPP

On 10 Jan 2010, at 23:49, Helveticus wrote:

I’ve seen this happen too. If it is a FW bug has it been reported to SoftPress.

Marcel


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Nathan,

If you can let me know how to repeat the bug then I’ll get it logged.

Joe

On 11 Jan 2010, at 09:29, Nathan Garner wrote:

Thank you all, I will go back in and re-do a couple of areas (cleaning it up if required) and see if that clears it.

If it is a bug, I will report it - if not I will report myself!

Thanks again.

Nathan Garner
Creative Director

Austin Wells Design Limited
One Elmgate Drive - Littledown - Bournemouth BH7 7EF
t 01202 301271 e email@hidden w http://www.austinwellsdesign.co.uk

Member of NAPP

On 10 Jan 2010, at 23:49, Helveticus wrote:

I’ve seen this happen too. If it is a FW bug has it been reported to SoftPress.

Marcel


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try these steps – you may have to fiddle with it a bit.

  1. Create a ‘body’ style with some text attributes.
  2. Create some HTML text on the page.
  3. Modify a run of text using the Inspector – change font and size.
  4. Select a subset of that modified text and again use the Inspector,
    but this time change the style back to whatever you set in step 1 by
    choosing the same attributes.
  5. Freeway runs its normal style cleanup routine, which wraps the
    subset with a body tag.

I haven’t seen this bug express itself with this particular tag, but
looking at the example posted, that is apparently the sequence. I have
definitely had this happen with different tags.

Walter

On Jan 11, 2010, at 4:39 AM, Joe Billings wrote:

Hi Nathan,

If you can let me know how to repeat the bug then I’ll get it logged.

Joe

On 11 Jan 2010, at 09:29, Nathan Garner wrote:

Thank you all, I will go back in and re-do a couple of areas
(cleaning it up if required) and see if that clears it.

If it is a bug, I will report it - if not I will report myself!

Thanks again.

Nathan Garner
Creative Director

Austin Wells Design Limited
One Elmgate Drive - Littledown - Bournemouth BH7 7EF
t 01202 301271 e email@hidden w http://www.austinwellsdesign.co.uk

Member of NAPP

On 10 Jan 2010, at 23:49, Helveticus wrote:

I’ve seen this happen too. If it is a FW bug has it been reported
to SoftPress.

Marcel


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Perfect, thanks.

Joe

On 11 Jan 2010, at 12:23, Walter Lee Davis wrote:

Try these steps – you may have to fiddle with it a bit.

  1. Create a ‘body’ style with some text attributes.
  2. Create some HTML text on the page.
  3. Modify a run of text using the Inspector – change font and size.
  4. Select a subset of that modified text and again use the Inspector, but this time change the style back to whatever you set in step 1 by choosing the same attributes.
  5. Freeway runs its normal style cleanup routine, which wraps the subset with a body tag.

I haven’t seen this bug express itself with this particular tag, but looking at the example posted, that is apparently the sequence. I have definitely had this happen with different tags.

Walter

On Jan 11, 2010, at 4:39 AM, Joe Billings wrote:

Hi Nathan,

If you can let me know how to repeat the bug then I’ll get it logged.

Joe

On 11 Jan 2010, at 09:29, Nathan Garner wrote:

Thank you all, I will go back in and re-do a couple of areas (cleaning it up if required) and see if that clears it.

If it is a bug, I will report it - if not I will report myself!

Thanks again.

Nathan Garner
Creative Director

Austin Wells Design Limited
One Elmgate Drive - Littledown - Bournemouth BH7 7EF
t 01202 301271 e email@hidden w http://www.austinwellsdesign.co.uk

Member of NAPP

On 10 Jan 2010, at 23:49, Helveticus wrote:

I’ve seen this happen too. If it is a FW bug has it been reported to SoftPress.

Marcel


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Walter. That has sorted it out. I will now go through the site re-applying.

Much appreciated.

Regards,

Nathan Garner
Creative Director

Austin Wells Design Limited
One Elmgate Drive - Littledown - Bournemouth BH7 7EF
t 01202 301271 e email@hidden w http://www.austinwellsdesign.co.uk

Member of NAPP

On 11 Jan 2010, at 12:23, Walter Lee Davis wrote:

Try these steps – you may have to fiddle with it a bit.

  1. Create a ‘body’ style with some text attributes.
  2. Create some HTML text on the page.
  3. Modify a run of text using the Inspector – change font and size.
  4. Select a subset of that modified text and again use the Inspector, but this time change the style back to whatever you set in step 1 by choosing the same attributes.
  5. Freeway runs its normal style cleanup routine, which wraps the subset with a body tag.

I haven’t seen this bug express itself with this particular tag, but looking at the example posted, that is apparently the sequence. I have definitely had this happen with different tags.

Walter

On Jan 11, 2010, at 4:39 AM, Joe Billings wrote:

Hi Nathan,

If you can let me know how to repeat the bug then I’ll get it logged.

Joe

On 11 Jan 2010, at 09:29, Nathan Garner wrote:

Thank you all, I will go back in and re-do a couple of areas (cleaning it up if required) and see if that clears it.

If it is a bug, I will report it - if not I will report myself!

Thanks again.

Nathan Garner
Creative Director

Austin Wells Design Limited
One Elmgate Drive - Littledown - Bournemouth BH7 7EF
t 01202 301271 e email@hidden w http://www.austinwellsdesign.co.uk

Member of NAPP

On 10 Jan 2010, at 23:49, Helveticus wrote:

I’ve seen this happen too. If it is a FW bug has it been reported to SoftPress.

Marcel


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options