Why is my hyperlink underlined?

I have changed the Links in the Page of Inspector and the underline button is off.

In Preview the text is not underlined, but as seen in the url below, it shows up in Safari, IE, and Firefox.

http://reeltimedvd.com/new_site/homepage3b2.html

What am I doing wrong?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On Jan 28, 2009, at 9:14 AM, george wrote:

In Preview the text is not underlined, but as seen in the url below,
it shows up in Safari, IE, and Firefox.

FWIW, I see no underlined links in Camino.

Richard

Richard Houston
Architectural Art
http://www.richardhoustonart.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Same her in Safari (3.2.1), no underlines
On 28 Jan 2009, at 17:33, Richard Houston wrote:

On Jan 28, 2009, at 9:14 AM, george wrote:

In Preview the text is not underlined, but as seen in the url
below, it shows up in Safari, IE, and Firefox.

FWIW, I see no underlined links in Camino.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Look now. I added more links and I see underlines on all of them.

Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On Jan 28, 2009, at 10:13 AM, george wrote:

Look now. I added more links and I see underlines on all of them.

I do see underlines now using Camino as my browser. I wish I could help
with your problem, but I’m sure a few of the more knowledgeable ones
will chime in soon.

Richard

Richard Houston
Architectural Art
http://www.richardhoustonart.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I am having a similar problem. I had a large body of html text with about 25 links to external pages. I used the ‘Text Link Style’ actions box to remove underlines and show a variation of rollover colors. It worked fine for a while, but now only reverts to the standard underlined version of text with no rollover actions. It stopped working for some reason that I cannot decipher. Has anyone had a similar issue? What am I missing?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It may help to look at the inspector under the T tab while the text is
selected and see what styles are applicable to it or its parent items.

If something is having multiple styles applied then this can be seen and
corrected.

hope this helps

regards
Brian

Grassman said recently:

I am having a similar problem. I had a large body of html text with about 25
links to external pages. I used the ‘Text Link Style’ actions box to remove
underlines and show a variation of rollover colors. It worked fine for a
while, but now only reverts to the standard underlined version of text with no
rollover actions. It stopped working for some reason that I cannot decipher.
Has anyone had a similar issue? What am I missing?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Bin Ra,
That was very helpful and showed a method of correction. Below is a more significant explanation of what was occurring that I wrote before getting your answer. With your suggestion, I was able to go to the ‘T’ tab on the inspector and see the different styles that accumulated on the suspect text. I removed each, one by one, to see the effect in Preview. The removal of one of the suspect style layers corrected the issue. I guess they just add up and then conflict with each other, negating the effects of the Link Text Style effects. It seems to work fine now that I individually eliminated each of the layered styles - and am still able to BOLD the text that I desire in the html box.
Thanks again for the suggestion.

[Previous to correction]
I have been playing with this extensively, rewriting and then exporting and reimporting the text from Freeway to Pages and back again. I think this is a bug. Here is what seems to be happening.
-Once the lack of link styles starts to take place, it spreads and corrupts whatever text is in the html box and cannot be corrected. Copying and pasting into a new html box has no effect. If the text does not want to be fully rewritten, it needs to be exported to a word processor and then reimported to a new html box. This seems to break all the links and starts over as a raw text block that can be styled and then re-linked.
-I reintroduced one link at a time [of about 25]. The first link worked fine and outputted properly to browsers. When I applied a BOLD style to the link text it still outputted fine. But as I added the next line of text with a link, the first linked text reacted poorly. It lost it’s underline. When exported to a browser it kept the color assigned, but re-underlined it.
-As more text links were added, the whole text linking choices started to fall apart in the Preview mode, losing first teh non-underlined choice, then loosing hover color, then just not applying any link styles. This was reflected in the browser viewing mode as well.
-So I guess it means that no text-styles, such as bold, can be added to hyperlinked text. Otherwise the Text Link Style fails. I assume this is not intended to occur.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

A few more comments…
With a lot of fooling about, it seems that this correction works very well in Freeway [Preview mode], but it does not fully translate to the browser viewing. In Safari and FIrefox the text that had been corrected with a removal of overlapping Text styles in the ‘T’ tab window, show up haphazardly in the browser windows. Some is corrected and some works partially. I have very carefully made sure that there are no remaining text style overlays in the offending lines, but it makes no difference in the browser output.
It is much improved, but still not correct.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Surely this is an easy fix.

I’ve tried following all of the other threads and it sure seems straight forward, but obviously a number of people are having the same issue.

Is there somebody out there who can answer this?

Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Fixed. Regarding my previous comments, I was even more meticulous in removing all the conflicting styles and it then it worked properly - in Preview and in browser mode with Safari and Firefox. Just have to make sure none of the layered styles are remaining in ‘spaces’ between words.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I was even more meticulous in removing all the conflicting styles and it then it worked properly -

This is a good habit to cultivate. In fact, an even better habit would be to create all your styles ahead of time as a template and then use that when starting a new page.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I still cannot remove the underline. The inspector shows no text styles applied but I can’t remove the underline from the the aA section of the inspector. When I remove the link, the underline goes away.

What could be going on?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Open up the styles Editor and check each style. It’s very likely you have conflicting styles set. You will have to check them all to determine which one is the problem, or… delete them all and create them again.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try this:

  1. Open up the Styles Editor and select your “style146”
  2. Click on the Extended button
  3. In the Name field type “text-decoration” without the quotes
  4. In the Value field type “none” without the quotes
  5. Click OK to exit editor.

freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Why style 146? I don’t see any of my text with that style (but I’ve changed things since I posted the link).

I tried the same thing with the pre-set style I use for the 3 text boxes in Start Your Project.

So far, still have the underlines.

Thanks for the effort.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Why style 146?

Looking at the source code of your site those menu items show style 146 being applied to them.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If you click on the cog in the top of the styles palette you get the options

Permanent styles Only

Temporary styles

If you have the 1st 1 checked you may not see style146 in your list

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I see style 146, but not on the text that is being underlined.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Is there any style applied to the text being underlined?

If so follow Chuckas instructions as above

Open up the Styles Editor and select your “style whatever”

Click on the Extended button

In the Name field type “text-decoration” without the quotes

In the Value field type “none” without the quotes

Click OK to exit editor.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options