Background music

What do I need to do to add background music (.wav) to a FreewayPro 6 page?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

http://www.zigpress.com/2009/10/30/10-reasons-websites-should-not-play-music/

But seriously you should never add music to your site unless there is a Play/Pause/Mute button

To get that simply drag your music file onto your FW page and it will automatically create the buttons for you when you view in your Browser.

Might be better with an mp3 file though - depends on your specific usage.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

David:

The music is Silent Night sung and played by a long-time parishioner known to most of the visitors to our site. I followed your links about why-you-should-avoid-background-music-on-your-website and think I am okay with this one.

I use this during the Christmas season. I followed your advice, which had worked for me in the past, but this time i get an error message Missing Plug-In. Any thought on this?

BTW, I have also followed your advice and converted the file to .mp3 format.

Harry

On Dec 12, 2015, at 12:55 PM, DeltaDave email@hidden wrote:

http://www.zigpress.com/2009/10/30/10-reasons-websites-should-not-play-music/

But seriously you should never add music to your site unless there is a Play/Pause/Mute button

To get that simply drag your music file onto your FW page and it will automatically create the buttons for you when you view in your Browser.

Might be better with an mp3 file though - depends on your specific usage.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

but this time i get an error message Missing Plug-In. Any thought on this?

Later versions of Safari have the QT plug-in disabled by default - Safari really expect you to use a native HTML5 Audio Tag these days.

You can re-enable the plug-in for your own use. Follow the link on the Error Tab when viewing the site.

But if your parishioners are primarily on Windoze and IE it may not be an issue - test and see.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I have also followed your advice and converted the file to .mp3 format.

If you have done that and your page is set to HTML5 then FW should generate the native Audio Tag for you - no QT plug-in required.

Post a link.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Dave:

We have a surprising number of parishioners using Macintoshes–including the rector–whom I wouldn’t want to exclude. What I would really like to have is a way to let the music play in the background one time while still viewing the home page (visitors could refresh their browsers to hear it a second time).

I have another page, one just for music, where I had another parishioner’s voice singing which I have since noticed no longer works.

Is there no way to fix this? I think the visitors would prefer to hear the parishioners’ voices (whom many will know) while viewing the home or music pages.

Harry

Sent from Harry’s iPad

On Dec 12, 2015, at 3:21 PM, DeltaDave email@hidden wrote:

but this time i get an error message Missing Plug-In. Any thought on this?

Later versions of Safari have the QT plug-in disabled by default - Safari really expect you to use a native HTML5 Audio Tag these days.

You can re-enable the plug-in for your own use. Follow the link on the Error Tab when viewing the site.

But if your parishioners are primarily on Windoze and IE it may not be an issue - test and see.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Is there no way to fix this? I think the visitors would prefer to hear the parishioners’ voices (whom many will know) while viewing the home or music pages.

Read my previous post about setting your page to HTML5

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I have another page, one just for music, where I had another parishioner’s voice singing which I have since noticed no longer works.

And post a link to pages where it doesn’t work.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

And just to add to this -

Once you have added the mp3 file to your page (and changed the page to HTML5) you will see the following options in the Inspector

There you can set alternate file sources (for other Browsers like FF ) and playing options like whether you want visible controls, autoplay, loop etc.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Dave:

I am in over my head. Where can I get instructions about setting a page to HTML5?

Harry

On Dec 12, 2015, at 3:58 PM, DeltaDave email@hidden wrote:

I have also followed your advice and converted the file to .mp3 format.

If you have done that and your page is set to HTML5 then FW should generate the native Audio Tag for you - no QT plug-in required.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Where can I get instructions about setting a page to HTML5?

Look in the page inspector with nothing selected on the page.

Then look under the 3rd Tab and in the Output Section there is a picker where you can choose your page level encoding.
Options range from HTML 4.01 Transitional up to XHTML5. HTML5 will be fine for your needs.

But please - post a link when you are having a problem with a page that doesn’t work. It makes it some much easier for us to see where you are going wrong.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Dave:

Thanks for your quick reply. I did as instructed but still no music and the music bar (at the bottom of the page) says Error.

Harry

Here is a link to the page:

http://www.stphilipsbrevard.org/music.html

On Dec 13, 2015, at 10:35 AM, DeltaDave email@hidden wrote:

Where can I get instructions about setting a page to HTML5?

Look in the page inspector with nothing selected on the page.

Then look under the 3rd Tab and in the Output Section there is a picker where you can choose your page level encoding.
Options range from HTML 4.01 Transitional up to XHTML5. HTML5 will be fine for your needs.

But please - post a link when you are having a problem with a page that doesn’t work. It makes it some much easier for us to see where you are going wrong.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Dave:

By the way the music bar at the bottom of the homepage http://www.stphilipsbrevard.org/ says Plug In Missing, in spite of changing the page to HTML5.

FYI: Both music files are .mp3.

Harry

On Dec 13, 2015, at 10:35 AM, DeltaDave email@hidden wrote:

Where can I get instructions about setting a page to HTML5?

Look in the page inspector with nothing selected on the page.

Then look under the 3rd Tab and in the Output Section there is a picker where you can choose your page level encoding.
Options range from HTML 4.01 Transitional up to XHTML5. HTML5 will be fine for your needs.

But please - post a link when you are having a problem with a page that doesn’t work. It makes it some much easier for us to see where you are going wrong.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Dave: All is well at the St. Philip’s web site. I hadn’t corrected the music settings to play automatically. Once I did the background music worked as advertised. Again, thank you for all your help. Harry

On Dec 13, 2015, at 10:35 AM, DeltaDave email@hidden wrote:

Where can I get instructions about setting a page to HTML5?

Look in the page inspector with nothing selected on the page.

Then look under the 3rd Tab and in the Output Section there is a picker where you can choose your page level encoding.
Options range from HTML 4.01 Transitional up to XHTML5. HTML5 will be fine for your needs.

But please - post a link when you are having a problem with a page that doesn’t work. It makes it some much easier for us to see where you are going wrong.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I strongly urge you to show the controls so that unsuspecting visitors can turn the sound off!

Something else that you should be very careful about is the use of space characters in File Names such as Silent%20Night,%20by%20Harvey%20Miller.mp3 - you shouldn’t use them as it can trip up some Browsers/OS.

FW helpfully adds the %20 (space character) for you but if you named the file Silent-Night-by-Harvey-Miller.mp3 - you would ensure compatibility.

You actually have a comma in there as well - definitely a big NO NO.

Stick to alphanumerics (0-9), (a-z), (A-Z) and underscores _ and hyphens - Nothing else!

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Dave:

I took your advice on both counts. I usually replace all capitals with lower case letters and spaces with underlines but this time I got lazy.

BTW, I was unable to get the Music Page’s background music to play and just a few minutes ago found the .mp3 file is defective. That’s odd: a 4.1MB music file just gives up the ghost?

Harry

On Dec 13, 2015, at 1:07 PM, DeltaDave email@hidden wrote:

I strongly urge you to show the controls so that unsuspecting visitors can turn the sound off!

Something else that you should be very careful about is the use of space characters in File Names such as Silent%20Night,%20by%20Harvey%20Miller.mp3 - you shouldn’t use them as it can trip up some Browsers/OS.

FW helpfully adds the %20 (space character) for you but if you named the file Silent-Night-by-Harvey-Miller.mp3 - you would ensure compatibility.

You actually have a comma in there as well - definitely a big NO NO.

Stick to alphanumerics (0-9), (a-z), (A-Z) and underscores _ and hyphens - Nothing else!

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

A 4.1 MB anything on a Web page that is not optional or user-directed is extremely hostile to mobile users with data caps. Please re-compress this (quash it down) or re-consider using it at all. It is perfectly fine to link to such a file, particularly if you note to the user that they will need to download something the size of the King James Bible (text-format) when they click that link. But requiring it on page load is extremely harsh.

Walter

On Dec 13, 2015, at 1:30 PM, HW & MC Sherwood email@hidden wrote:

BTW, I was unable to get the Music Page’s background music to play and just a few minutes ago found the .mp3 file is defective. That’s odd: a 4.1MB music file just gives up the ghost?

Harry


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Walter:

You are right. If I can get a replacement file I’ll squeeze it down to less than one-half MB or give up on using it.

Harry

On Dec 13, 2015, at 1:36 PM, Walter Lee Davis email@hidden wrote:

A 4.1 MB anything on a Web page that is not optional or user-directed is extremely hostile to mobile users with data caps. Please re-compress this (quash it down) or re-consider using it at all. It is perfectly fine to link to such a file, particularly if you note to the user that they will need to download something the size of the King James Bible (text-format) when they click that link. But requiring it on page load is extremely harsh.

Walter


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options