Bug report

I’m just starting to tinker with the beta and may have come across a bug. However, after filling out the bug report form, when I submit it a 404 error page is returned so I’m not sure if the report has been sent. Just in case, I’m copying the report below. Someone else may like to try out the steps too! See what you think.

Not sure if this is a bug or me…

  1. Create master page
  2. Create graphic item and import a faded screengrab to use as a template. Size graphic frame to fit image
  3. Align, lock, add guides and create layered graphic items and HTML boxes above.
  4. New home page based on master.
  5. Uncheck Show for the screengrab in the Master. Screengrab disappears and all other items stay visible as intended in both master and home page.
  6. Page view select Preview - page publishes, guides disappear but screengrab becomes visible again when it should remain invisible

Cheers
Pete

On 8 Feb 2008, at 16:21, Pete MacKenzie wrote:

Someone else may like to try out the steps too! See what you think.

I think you may be getting family problems with parents and children!
It may be a bug, so I’ll look at getting it checked and logged anyway.

When you draw items over an existing item, they will be children of
the main item. By hiding the main background image, the children will
tend to follow suit.

Perhaps, to make things easier, it might be better to size the
template image as you want and import it as a JPEG or PNG as a
background to the master page. Then you can create items on the page
freely without worrying about which items are children of which parents.

When you’re ready to use the master page without the background,
simply use the Inspector to remove it again.

Hope that helps.

Heather


“Freeway - Web Design for All”


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Another thought,

Show will only show/hide within Freeway. If you don’t want it to
publish then uncheck Publish too.

Does this solve the problem?

On 8 Feb 2008, at 16:41, Heather Kavanagh wrote:

On 8 Feb 2008, at 16:21, Pete MacKenzie wrote:

Someone else may like to try out the steps too! See what you think.

I think you may be getting family problems with parents and children!
It may be a bug, so I’ll look at getting it checked and logged anyway.

When you draw items over an existing item, they will be children of
the main item. By hiding the main background image, the children will
tend to follow suit.

Perhaps, to make things easier, it might be better to size the
template image as you want and import it as a JPEG or PNG as a
background to the master page. Then you can create items on the page
freely without worrying about which items are children of which
parents.

When you’re ready to use the master page without the background,
simply use the Inspector to remove it again.

Hope that helps.

Heather


http://www.softpress.com

“Freeway - Web Design for All”


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

thanks Heather

I think you may be getting family problems with parents and children!
It may be a bug, so I’ll look at getting it checked and logged anyway.

When you draw items over an existing item, they will be children of
the main item. By hiding the main background image, the children will
tend to follow suit.

I thought it might be this, and Doh! - indeed at my first attempt
when I first hid the screengrab I’d forgotten to uncheck combine and
the layer on top did disappear. However I then made sure Combine was
unchecked on all items and it still does the same behaviour.

Perhaps, to make things easier, it might be better to size the
template image as you want and import it as a JPEG or PNG as a
background to the master page. Then you can create items on the page
freely without worrying about which items are children of which
parents.

I was hoping to be able to toggle the visibility on and off to get
positioning right before removing the image completely. There are
always incremental adjustments between Page and Preview text which
are harder to see when the two images are sitting on top of each
other. This would presumably affect anybody trying to have some
objects hidden temporarily though, wouldn’t it?

When you’re ready to use the master page without the background,
simply use the Inspector to remove it again.

Thanks
Pete


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Aha, how dim of me! Yes, problem solved. I hadn’t twigged that Show
was limited to the layout side. Of course it makes sense now…
Somehow I knew it was down to me. Bugs seem to fly at an altitude
rarely reached by my level of expertise so I was a bit puzzled by
this. Many thanks, Joe.

Cheers
Pete

On 8 Feb 2008, at 17:05, Joe Billings wrote:

Another thought,

Show will only show/hide within Freeway. If you don’t want it to
publish then uncheck Publish too.

Does this solve the problem?

On 8 Feb 2008, at 16:41, Heather Kavanagh wrote:

On 8 Feb 2008, at 16:21, Pete MacKenzie wrote:

Someone else may like to try out the steps too! See what you think.

I think you may be getting family problems with parents and children!
It may be a bug, so I’ll look at getting it checked and logged
anyway.

When you draw items over an existing item, they will be children of
the main item. By hiding the main background image, the children will
tend to follow suit.

Perhaps, to make things easier, it might be better to size the
template image as you want and import it as a JPEG or PNG as a
background to the master page. Then you can create items on the page
freely without worrying about which items are children of which
parents.

When you’re ready to use the master page without the background,
simply use the Inspector to remove it again.

Hope that helps.

Heather


http://www.softpress.com

“Freeway - Web Design for All”


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options