Carousel help

Hi,

I’m trying to set up a carousel action on one of my pages and am having difficulties. I can see the Carousel Button and Carousel Tab actions but am I missing the Carousel action itself? I looked at this thread and it seems that way: http://www.freewaytalk.net/thread/view/30348#m_30350

I’ve looked under page actions and didn’t see it. I’ve tried to follow Walter’s tutorial (which is very easy to understand!) on his homepage for the action and even reinstalled the Protaculous files from his site. Am I missing something here?

Thanks for any help!

Brian


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You must select a layer (in this case the group of individual panes)
in order to apply Carousel. Carousel will only apply to a layer.

See Step 4 in the directions – that’s the key here.

Walter

On Jul 14, 2008, at 1:03 PM, Brisprad wrote:

Hi,

I’m trying to set up a carousel action on one of my pages and am
having difficulties. I can see the Carousel Button and Carousel Tab
actions but am I missing the Carousel action itself? I looked at
this thread and it seems that way: http://www.freewaytalk.net/
thread/view/30348#m_30350

I’ve looked under page actions and didn’t see it. I’ve tried to
follow Walter’s tutorial (which is very easy to understand!) on his
homepage for the action and even reinstalled the Protaculous files
from his site. Am I missing something here?

Thanks for any help!

Brian


dynamo mailing list
email@hidden
Update your subscriptions at:
List Options | FreewayTalk


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks once again Walter! I went back and tried it again following your directions precisely and got it. This is a really neat effect. Thank you for taking the time to make something so cool.

Where do you find time to write and update actions as well as run your own company and post so much here helping others? Do you sleep? :slight_smile:

Thanks again!

Brian

On 14 Jul 2008, 5:11 pm, waltd wrote:

You must select a layer (in this case the group of individual panes)
in order to apply Carousel. Carousel will only apply to a layer.

See Step 4 in the directions – that’s the key here.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometimes. I mostly just type really fast, that’s all.

Walter

On Jul 14, 2008, at 4:32 PM, Brisprad wrote:

Do you sleep? :slight_smile:


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I don’t see the Carousel action. What I see is Observer. Is this the same?


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Carousel can only be applied to an HTML layer. Perhaps you are trying
to apply it to something else? No, they are not the same thing at all.

Walter

On Sep 5, 2008, at 3:44 PM, george wrote:

I don’t see the Carousel action. What I see is Observer. Is this
the same?


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I must be dense today, because this should be simple.

I created an HTML box (Box1).
Then I created another HTML box within Box1 (Box2 and Layer1).
Then I duplicated Box2 twice (Box3 & Box4)
I grouped Box1,2,3 (Layer2)
I try applying an Item:Action to Layer2 and there is no Carousel action. I also tried applying it to Layer1, no dice.

I created a graphic box and can apply the Carousel Button and Tab actions to it (obviously doesn’t do anything without the main action).

I must be missing something obvious.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try starting over.

Draw an HTML box on the page. Make it a color.

With that box selected, use Edit > Duplicate to make 3 more just like it. Use offsets of 0,0 to be sure that there is no position change between them.

Click on the header at the top of the Site pane until it shows the items in the page (rather than the entire site).

At this point, you should see a list of four items in the Site pane:

item1
item1a
item1b
item1c

Click on each item within that list in turn, and change its color using the Inspector so that each one is a different color.

Now drag a selection rectangle around one corner of the stack (or use Shift-click to select all of the elements within the Site pane), and use Item > Group from the main menu to group the elements together. (One possibility here is that you are using the Mac-standard Apple-G for Group, which is unfortunately not the case in Freeway). With the group selected, try applying the Carousel action to the group.

I suspect what might be happening here is that you have more than one thing selected when you are trying to apply the Action. Grouping the elements gives you one logical object to attach the Action to.

Walter


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Well I followed your steps exactly and I am still not seeing the Carousel action. When I look in my Library/Application Support/Freeway folder I see the Protaculous action. In fact I deleted it and re-installed it.

I did create it correctly originally (I understand how to group properly), but started from scratch just to double check I didn’t have something wrong.

Seems bizarre.

Here’s the link:

http://reeltimedvd.com/slider/


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Ok, I gave it another go after closing Freeway and re-starting the machine. Now I can apply the Carousel action!

Now I am having problems with the Button and Tab actions.

The buttons do nothing and the tabs simply bring up the new layer very similar to Target/Show.

The only thing that actually carousels the panes are when I put a value in the auto-glide box.

I didn’t see any discussions regarding Button or Tab, so I am a bit stumped.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try dragging a selection around the Carousel and all of it’s controls, and grouping that. Everything should work then.

Walter


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks. I was wondering how the items referenced each other. It should have been obvious.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Does having a CSS Menu affect Carousel?

I cannot get the action to pull up on my page even though I can get it to work fine on a blank page. The only difference I can see is my page has a CSS menu.

Thanks.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The other thing I noticed is I have some Rollovers, but they are not tabs for the Carousel.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Could you post a link to a broken page? I can look at it in Firebug and see if anything sticks out.

Walter


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Here’s the link.

http://reeltimedvd.com/new_site/how-gettingstart.html

I can’t get the Carousel or Button action to show.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

This page does not have the Carousel or the Carousel button applied anywhere that I can see. I can see where you want to have it, but it doesn’t appear to have worked. The glider.js library is not applied to the head of the page, and the various functions that Carousel would write are not in there either.

Walter


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yes, I know. I am not getting the actions to show in the Items:Actions list for this page. I don’t know if there is some conflict going on that won’t allow Carousel.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Is the item you are trying to apply it to a layer? It must be, or this won’t work. What HTML level is the page set to?

Walter


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yes, I believe it is a layer. I created an HTML box and then added some HTML and Graphic child boxes within it, duplicated it, and grouped them together. The grouped item appears to be on the ‘highest’ layer level, judging by the box next to its name (it is as far left as any other layer other than the Page icon).

I don’t know how to see what HTML level the page is set to. If you mean the page icon in the list, it is the furthest to the left/highest level.


dynamo mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options