Changes to website aren't being saved properly and can't be published.

In the past, I never had trouble with X-way uploading changes I make to my website. But now, none of the changes I make to my site are being saved properly to the “Site Folder”. I can make changes in X-Way and it looks like the changes are saved, but the changes aren’t saved to the respective .html files in the “Site Folder”. I try uploading my entire site folder to my web server and none of my changes appear on my online site. It doesn’t make sense because if I shut down X-way, when I restart it my changes are still there, but the files in my “Site Folder” are still the old files and I still can’t get my published site to reflect the changes I’ve made. What is going on?


Are you publishing the site (File/Publish) after you make the changes?

Hi, Jeremy, and thanks for the reply.
I have tried using the “Publish” command, but nothing happens. As far as I know – and based on what is written in the Xway beta user manual – the “Publish” function is still not usable. There are Xway instructions on how to upload from the “Site Folder” using Cyber Duck. My problem is that files in the “Site Folder” aren’t getting updated. That makes me think Xway must be saving my new .html files somewhere other than in the “Site Folder”.

A quick update:
Just now, instead of using the “Save” command in the file menu I closed the website project and let X-Way prompt me to save the file before closing. I saved the file that way and it appears that my changes are now reflected in the “Site Folder”. I dragged the updated .html files from the “Site Folder” to my web server via Cyber Duck and it appears that the new files are now online and ready to go. The problem now, though, is that my web browsers won’t show the new versions when viewing the pages online. Using Cyber Duck I can see that the .html files online have been updated, but my browsers won’t load the updated pages…

The Publish command publishes your site to the Site folder. If you don’t do this, the Site folder won’t be updated.

Publishing also happens automatically if you preview your site in a browser.

This is the same in Freeway and Xway, except that Freeway also publishes automatically if you use the Upload command (which we will add in a future version of Xway).

Oh, well that can make a big difference! I think that’s probably the real reason why I eventually had files updated (it wasn’t because of how I saved the project). I do remember hitting the “Publish” command once just to prove to myself that it didn’t do anything… but it turns out that it did do something.

Unless I missed something somewhere, I don’t recall this important bit of information being mentioned in the manual…

Thanks for the help! Hopefully when I make future adjustments to the site I’ll now have smooth sailing.

This is what the manual says:

Publishing a document
Select Publish from the File menu (shortcut: ⌥⌘P) to publish a document. This publishes the document into a Site folder that is within the document. Xway outputs HTML5 pages in a readable indented format (using 3-space indents).

If you previously used Freeway you might have got used to publishing happening automatically before upload (Xway will also do that when we add Upload).

My confusion was because I assumed “publish” meant uploading (because it did that in Freeway), so I thought that because the “Publish” command doesn’t currently upload that it was currently disabled. That caused me to gloss over the part about “publishing to a folder” because I assumed that command hadn’t yet been implemented. Sorry for my lack of technical prowess.

Thanks for your patience and explanations!

There are separate Publish and Upload commands in Freeway, and Publish is essentially the same in Xway as it is in Freeway. But I agree that the use of “Publish” (in Xway and Freeway) could be slightly misleading, since it seems to suggest that a Site is being made public (i.e. uploaded).

Well, it’s been quite a while now since I’ve used Freeway so I guess that I’m not remembering all the steps properly. Sorry for my confusion. And thanks again for your help.