CSS Menu - Submenu not showing

I have had a functioning menu using the CSS Menu action, and in further organizing my site, I finally added submenus. I was able to get the dropdown submenus working no problem on a selection of pages all based on the same master, however can’t get the dropdowns working on any other pages. [Working pages: Home, Stories, Manners, Training, Animal Additions, Resources. Non-working pages: Everything else.]

I have cut and pasted the menu (and all parent divs) to all masters and have verified all changes across all pages. And have tried fiddling with things on one of the broken pages… z-index, Overflow: visible/hidden. Changing parent divs height to flexible/fixed, cutting and pasting the working menu and varying collections of parent divs from working pages to non-working pages.

To my eye, all seems to match between working and non-working menus. But perhaps there is truth in the code that I cannot find. Any help is appreciated.

Thank you!

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try taking the Google analytics off one of the non-working pages. I am seeing an error with its code.

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-61361001-1
UA-61361001-1
', 'auto');
  ga('require', 'linkid', 'linkid.js');
  ga('send', 'pageview');
</script>

But admittedly i see the same error on pages where the menu does work - but worth trying to rule it out.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hmm… I had the Google analytics applied to the Site Folder and have removed it with no apparent change to the menu.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

An added piece of information… it seems the submenus DO show up once the Responsive menu is activated at the specified breakpoint.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Using the Instagram Page as my tester, I have deleted the CSS Menu action and reapplied. No difference. Changed the structure of the list – items will show up as main menu links but still no submenu dropdown. Tried various z-index configurations.

Here is a link to the file: Dropbox - Error

Really quite stuck on this one!

Thank you,

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options