Dashes no longer dashes

My site has been in Freeway for several years. I make liberal use of the genuine dash character (on the Mac, shift-option-hyphen).

I recently upgraded from Freeway Pro 4 to the most recent version. Suddenly the dashes on my pages, which used to show up just fine in all browsers, now show up as — . The original page source still has the correct dashes.

How do I get my dashes to render properly?

http://macsrwe.com/macprices.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Check to make sure that your page is set to Unicode (not Automatic) encoding in the Page Inspector.

Walter

On Jan 6, 2014, at 4:49 AM, macsrwe wrote:

My site has been in Freeway for several years. I make liberal use of the genuine dash character (on the Mac, shift-option-hyphen).

I recently upgraded from Freeway Pro 4 to the most recent version. Suddenly the dashes on my pages, which used to show up just fine in all browsers, now show up as — . The original page source still has the correct dashes.

How do I get my dashes to render properly?

http://macsrwe.com/macprices.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Check to make sure that your page is set to Unicode (not Automatic)
encoding in the Page Inspector.

That was my first thought. His link is dead, so I tweaked it to to

You can see some kind of garbage characters there and within the site, and
yes the page is set to UTF-8 (FWP6). The garbage chars are also in the raw
HTML, which made me wonder if something else was going on. What, I can’t
figure out.


Ernie Simpson


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The server is sending the file with the wrong charset encoding, and the browser is accepting that in preference to the encoding in the page:

Content-Type text/html; charset=iso-8859-1

Fixing this will require a change at the server level, but a quick interim fix will be to switch the page the Windows Latin in the Output tab. Freeway will encode the non-ASCII characters using escape sequences, and the page will look correct.

Walter

On Jan 6, 2014, at 11:36 AM, Ernie Simpson wrote:

Check to make sure that your page is set to Unicode (not Automatic)
encoding in the Page Inspector.

That was my first thought. His link is dead, so I tweaked it to to
http://macsrwe.com/

You can see some kind of garbage characters there and within the site, and
yes the page is set to UTF-8 (FWP6). The garbage chars are also in the raw
HTML, which made me wonder if something else was going on. What, I can’t
figure out.


Ernie Simpson


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Fixing this will require a change at the server level,

The server is administered by a commercial hosting company. If you could express the required fix succinctly in the appropriate technical language, I will open a ticket with them and request that they do it.

However, I have to say that I’m pretty confident that the upgrade to Freeway Pro somehow caused this problem. For evidence, see Grand Avenue Broadband -- Features – from another site I maintain in Freeway, on the same hosting service. All the dashes are fine and dandy. The difference is that I haven’t republished this site since upgrading to the newest Freeway Pro.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

However, I have to say that I’m pretty confident that the upgrade to
Freeway Pro somehow caused this problem. For evidence, see
Grand Avenue Broadband -- Features – from another site I maintain
in Freeway, on the same hosting service. All the dashes are fine and
dandy. The difference is that I haven’t republished this site since
upgrading to the newest Freeway Pro.

I cannot agree as this second sample was clearly generated by Freeway Pro
6

  meta http-equiv=Content-Type content="text/html; charset=UTF-8"
  title>Grand Avenue Broadband -- Features</title
  meta name="viewport" content="width = 800, minimum-scale = 0.25,

maximum-scale = 1.60"
meta name=“GENERATOR” content=“Freeway Pro 6.1.2”


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The two pages are identical in terms of their code at the top of the page (both are HTML 4.01, both have identical Content-type meta tags (which is the only thing that Freeway can actually control, outside of the encoding of the text file itself).

The difference between them is that the Grand Ave Web server is not sending a charset component to the Content-type header, and the Macs-r-We server is. The Macs-r-We server is sending Content-type: text/html; charset=iso-8859-1, while the other server is sending only Content-type: text/html. That’s the actual difference here that matters.

Walter

On Jan 6, 2014, at 1:31 PM, macsrwe wrote:

However, I have to say that I’m pretty confident that the upgrade to Freeway Pro somehow caused this problem. For evidence, see Grand Avenue Broadband -- Features – from another site I maintain in Freeway, on the same hosting service. All the dashes are fine and dandy. The difference is that I haven’t republished this site since upgrading to the newest Freeway Pro.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Ask them to tweak the Content-type header, so that it either does not specify a charset, or specifies utf-8 as the charset. The full header for HTML should always be:

Content-type: text/html; charset=utf-8

That’s been the universal standard since the late '90s.

Walter

On Jan 6, 2014, at 1:31 PM, macsrwe wrote:

The server is administered by a commercial hosting company. If you could express the required fix succinctly in the appropriate technical language, I will open a ticket with them and request that they do it.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Cause of the problem found. The .htaccess file for macsrwe.com included the line:

AddType ‘text/html; charset=ISO-8859-1’ html

This line was gratuitously added on 12/20/13 by someone at the hosting service without notification or permission. Removing it cured the problem.

Thank you all for your help.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options