Error when submitting form

I’ve put together a brief online survey for a project we’re working on but I’ve run into a problem. I’ve used the PHP feedback form action. Most of the questions are multiple choice but the final questions ask for name (first, last) and email address which are optional. None of the fields are required, but unless the name and email address fields are completed, the form generates an error. Any ideas what to do? I want respondents to be able to submit the form without providing name and email. Thanks in advance.

https://flippitback.com/survey/


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Another odd thing. At the end of the email, the action includes information about “x” and “y” which are not inputs:

x: 70
y: 18

The numbers vary from submission to submission. It’s not a problem but wondering if anyone has any idea what those are?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

You are using an image as the submit button. PHP includes these, which are the offsets from the top-left corner of the image showing the exact pixel that was clicked.

Walter

On Feb 23, 2020, at 11:09 AM, Richard Cacciato email@hidden wrote:

Another odd thing. At the end of the email, the action includes information about “x” and “y” which are not inputs:

x: 70
y: 18

The numbers vary from submission to submission. It’s not a problem but wondering if anyone has any idea what those are?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I don’t recall the exact part of the interface where you set this, but this is happening because you have used the defaults, which means the form submission is sent From: the person who fills it out. You can set the Action so that it always sends From: some other address. Once you do that, I believe the name and e-mail (which are used to compose the From: header) no longer are required.

Walter

On Feb 22, 2020, at 11:09 PM, Richard Cacciato email@hidden wrote:

I’ve put together a brief online survey for a project we’re working on but I’ve run into a problem. I’ve used the PHP feedback form action. Most of the questions are multiple choice but the final questions ask for name (first, last) and email address which are optional. None of the fields are required, but unless the name and email address fields are completed, the form generates an error. Any ideas what to do? I want respondents to be able to submit the form without providing name and email. Thanks in advance.

https://flippitback.com/survey/


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Walter, I set the “from” address in the PHP Feedback Form Action to my email address (under “Missing email address options” which I’ve set to “Use a specific e-mail address”), but the problem persists. As I wrote, I also checked the “Ignore empty fields” box. I’ve removed the name and email fields from the live version for now. Let me know if you have any other idea what the problem might be.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

You could re-name them to something else (just the field name – you can leave the label alone, so the user isn’t confused). I believe specific names of the fields are treated specially. Try email_address and see if that makes it non-required.

Walter

On Feb 23, 2020, at 2:34 PM, Richard Cacciato email@hidden wrote:

Hi Walter, I set the “from” address in the PHP Feedback Form Action to my email address (under “Missing email address options” which I’ve set to “Use a specific e-mail address”), but the problem persists. As I wrote, I also checked the “Ignore empty fields” box. I’ve removed the name and email fields from the live version for now. Let me know if you have any other idea what the problem might be.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Walter, I named the fields first_name, last_name, and email_address and that seemed to work. Odd, but it solved the problem. Thanks!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

So the form error is fixed but I applied the Smoothscroll action and it doesn’t seem to work. Go to the survey here
https://flippitback.com/survey/ and click on the link after question 1. It works on other sites but for some reason not on this one.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hmm. I just got an odd javascript error. I deleted the action, reapplied it, and now it works. Sort of like kicking the tires on the Moon Rover…


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Your previous page had http:// references to Prototype and Scriptaculous, but you’re serving it under https. If you get that same problem again, the solution is to apply the HTTPS Helper Action to the same page.

Walter

On Feb 24, 2020, at 7:22 PM, Richard Cacciato email@hidden wrote:

Hmm. I just got an odd javascript error. I deleted the action, reapplied it, and now it works. Sort of like kicking the tires on the Moon Rover…


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

In fact, turns out it worked fine when I previewed on my Mac locally but I noticed it didn’t on the live site and was puzzled. That fixed it. Thanks, Walter!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options