Freeway 6 Send Form Action bug

Looks like there’s a bug in Freeway 6 and the Send Form action.

If you apply the Send Form Action to an inline

, each change > publish creates another FW_SendForm_index_form.php file named FW_SendForm_index_form1.php, FW_SendForm_index_form2.php etc the filling the site folder.

FW5.6.5 used to do this also.

David Owen { Freeway Friendly Web hosting and Domains }

http://www.ineedwebhosting.co.uk | http://www.PrintlineAdvertising.co.uk


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yes I had noticed this and told SP Towers - they are working on a fix.

Actually it was some time ago they told me that!

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I really hope so, any modern site is inline and this really puts a kibosh on using Freeway built in forms. I’ve been really struggling with this with old 5.5.6 sites because of this.

David

http://www.printlineadvertising.co.uk

On 7 Nov 2013, at 19:34, “DeltaDave” email@hidden wrote:

Yes I had noticed this and told SP Towers - they are working on a fix.

Actually it was some time ago they told me that!

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi guys,

This doesn’t stop the form from working, does it?

Joe


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

This doesn’t stop the form from working, does it?

Not unless when you do housekeeping you delete the wrong version - but if you leave it alone it is fine.

Distressing for OCD sufferers to see all those files in there though!

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

One site has 5 dedicated forms and is frequently updated. It makes me cringe to see all the files being created. I ended up deleting all the files delete files out of the site folder before a publish, rinse, repeat. I just assumed it was just FW5 that was effected.

The other option is to do a dedicated form that posts to the first php script and leave that script on the server (assuming the details don’t need to changed)

David

http://www.printlineadvertising.co.uk

On 7 Nov 2013, at 20:17, DeltaDave email@hidden wrote:

Not unless when you do housekeeping you delete the wrong version - but if you leave it alone it is fine.

Distressing for OCD sufferers to see all those files in there though!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The other option is to do a dedicated form that posts to the first php script and leave that script on the server (assuming the details don’t need to changed)

If you have created a ‘standard’ form processor using the action then it can be reused like that (my-form-processor.php) and it will pretty much deal with anything you fling at it.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If you have created a ‘standard’ form processor using the action

Clarification: I must admit that I haven’t done it with the SendForm action but certainly have with PHPFF

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The bug is still there in 7.0.2

I just deleted FW_SendForm_index_Form83.php.

I have a total of 1 form on the site. Every time I republish, FW creates 6 new FW_SendForm_index_FormXX.php files

Shouldn’t there just be one?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options