I broke my image viewer

I hope someone can help as this is really old code. Im in the middle of revamping both of my websites and I think I have managed to break some code Walter did for me many years ago. Im on Freeway 5.5 and the code works on one site but not the other. I dont remember touching it but both sites run on the same version of Expression Engine. The pages are here and its the image changeover that no longer works on vintagelcd. Thank you for any help.

I’'ve made a couple of example of what I think is the same code, one works one does not

thank you in advance


This is all happening because you have a mix of secure and insecure references to various JavaScript libraries on content delivery networks, as well as to image resources and other parts of the site. When I wrote this, HTTPS wasn’t a thing except for e-commerce sites and big brands. The early Actions didn’t consider this either. It’s all fix-able, either by removing the http: part of the URLs, so they just start with //, or in the case of the Action-generated code, updating to later versions of those Actions (which used the secure form either exclusively, or by configuration).

You can see all these errors by enabling the Developer menu in Safari (Preferences/Advanced – Show features for Web developers and then choosing Develop / Show JavaScript Console from the main menu while you are browsing your site on the server.


Thanks Walter although Im a bit out of my depth. I’ve gone back and changed some of the urls. Im still getting errors in Safari developer that I dont really understand. I also noted the php is not creating increments like it does in the digital-watch site. Iy just returns 1, 1, 1

This is the test page for vintagelcd



The one you missed is to the Prototype library, which in turn meant that all the other JavaScript on the page is not going to work. As far as the PHP goes, I was able to see the PHP in the source code of that test page, which means that either PHP is not enabled on your server, or the filename of the page doesn’t end in .php, so the server isn’t trying to run that code.

The link to Prototype is coming from the Protaculous Action (I think) and if you upgrade to a newer version of that Action, you will be able to choose HTTPS links to the Google Ajax CDN.


Well how about that I have spent a full day trying to work this out only to find that somewhere along the line the js folder has turned into JS. and other than the issues Walter turned out that was why everything stopped working. Thank you for your help Walter.



You’ve also got a few hard-coded references to images and stylesheets that point to your own site with an http prefix. Not sure how those are getting in there, as Freeway only ever makes relative URLs (…/some/path/here) without prefixes when you link to images and such.

Most of it is all generated by EE walter, they told me it is necessary to use https, thats why you are seeing thos and why I changed some, that I porbably shouldnt. Its not all Freeway generated. I am now struggling with the cookie not recognizing prototype.js is loaded, unless its not. The file is in the correct place with the correct url.



On the last page you posted, the link to the prototype.js script in the page head was to Google’s Ajax CDN, but to the http rather than https URL. If you have that file locally (no need to have it come from Google) then you can simply replace that link with a relative url to the file.

That’s brilliant Walter its got my History cookie working on vintagelcd,com(not on digital-watch though). I have noticed Im calling the scripts twice but in slightly different ways, is that necessary? Thank you for your help Walter. Im trying to have a good clean up and streamline, with a bit of redesign while I upgrade to EE 7 in the background after the scary migration to new providors. Shows how good Freeway is when its still running even with newer technology. regards Adam