Images in posts

A question for Walter - when he has nothing better to do.

You used to be able to include an image within your post which was then viewable in the online version.

This capability was lost a couple of months ago.

inspector

This code used to work

![description]("http://www.deltadesign.co/_images/deltapic179.jpg")

But something changed and now it doesn’t

D


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You don’t need the quote marks around the URL. That’s what is throwing things off.

Walter


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

OK - so did that creep in as part of a rewrite/upgrade

I am so happy I can post images again - just a pity the old ones are gone.

Thanks Walter

D


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

They never should have been there: http://daringfireball.net/projects/markdown/dingus

Walter

On Sep 23, 2011, at 7:59 PM, DeltaDave wrote:

OK - so did that creep in as part of a rewrite/upgrade

I am so happy I can post images again - just a pity the old ones are gone.

Thanks Walter

D


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Dave, I just added another filter to clean up any image tags that were not coded according to the Markdown specs (i.e., with the image URL wrapped in quotes). For the record, any text in quotes within the URL part of the Markdown image tag is interpreted as the image’s ALT attribute. I’m not sure what PHPMarkdown does if it encounters an image tag with an alt but no src, but anyway, a little regular expression magick later and any tags that were coded that way are patched up.

Net result for anyone looking over this thread in the future is that the original post (showing the problem) doesn’t show that problem any more, because I patched around it.

Walter


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sorry, I got that just slightly wrong. Here’s the official image tag Markdown syntax:

![Alt Text](imageURL "Title Tag (optional)")

The imageURL attribute must be a complete http-and-everything URL to the image itself. The image URL is not quoted, in any case, and is separated from the optional Title attribute, which IS quoted if it is used.

Whew.

Walter


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Brilliant Walter - they are all back!

I was concerned that in earlier posts viewers would be missing out on the ‘picture says a thousand words’ part and be flummoxed.

with the image URL wrapped in quotes…

What I dont understand is why it used to work if it was fundamentally wrong. Someone here told me that was the way to do it. I am not smart enough to have discovered it myself.

WWWDWY

D


offtopic mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options