Intaglio and macOS 11.6

I am a long-time user of Intaglio and am very sad to see it disappear. That said, I was hoping to keep using it for some time. However, I have found that it no longer works following the update to macOS 11.6 on three different machines. Has anyone else found the same thing?

HI Tyson,

We are all concerned abougt the abandonment of Intaglio. I’m still running under Mojave but just received a new M1 iMac and will test Intaglio when I set it up and update the OS.

Jack

Hi Jack. Thank you so much for your reply!

I’ve been using Intaglio for MANY years and reading this thread for a long time, too. Happily, I found a suggestion buried in one of the posts which has got Intaglio working for me again (with macOS 11.6).

Clicking on Window/Workspace/Floating Windows and then restarting the program worked for me.

That said, I really wish there were some way we could connect with Nick Nallick – and convince him to restart development himself (or let someone else do so). It is such a great program!

So what is the latest Mac OS that Intaglio works with 100% with no workarounds or other odd issues? DO NOT laugh, but I am still using a MacMini from 2009 running El Capitan (DOH!) and am trying to sort out how I can both upgrade my machine (cause El Capitan is no longer supported and for no other reason) AND still use Intaglio.

I was using Appleworks WELL after it died. And I held on to a Windows 97 machine for YEARS just so I could still play The Neverhood…
:smiley:
Mary Anne

On my system, Intaglio worked perfectly until the update to macOS 11.6. Previous versions of Big Sur were fine here.

While I was able to get iIntaglio working with 11.6 by changing it to Floating Windows mode, there are still a couple of very small problems. For example, the bottom side and right side of the Intaglio window now have two tiny lines running through them that obscure things a bit. So the “fix” got the program back to 99% or so.

I found it a lot less than 99%. One of my main reasons for using Intaglio from the outset was that I had a choice not to use Floating Windows – as these are usually so poorly implemented, and you just end up with too much app furniture obscuring your task — only Claris (MacDraw, ClarisDraw, ClarisCAD, etc.) ever got this right IMHO, with each pallette minimising to a convenient ‘stack’ at the top right. I had a nice narrow bar down the right in Intaglio and all the Inspectors in it — worked very well. So having to use Floating Windows was a deal-breaker for me. Otherwise, the only thing that bothered me with Intaglio was the lack of trackpad support for pinch-to-zoom, but I could live with that.

Under 11.6.1, those additional grey lines were also just not tolerable. I then started a search for a replacement. As everyone finds, this is not easy and takes ages, as everyone had different ‘essential functions’ and other stuff they either ‘must have’ or ‘can’t cope with’. For me, it’s solid, scaled 2D drawing with grouping, ‘scale whole group’, allignment, and basically the whole MacDraw-type toolset, with reasonably accurate dimensioning so that you can either ‘type dims as you draw’ or select an object and then edit the dimensions by typing them in. I also need to drop in PDFs or PNGs as a backdrop, and export the lot to PDF or PNG. There are actually very few apps that seem to have this collection of capabilities, and all the obvious candidates (EasyDraw, etc.) appear to have been ported from some Fisher-Price Windows version and have user interfaces designed by brain-dead monkeys.

But I found one, so I thought I should share it because there’s a chance that someone else has the same requirements and sensibilities. It’s Graphic (on the App Store for 25 of our UK pounds , formerly called iDraw, and seemingly with a slightly troubled parentage, with AutoDesk (cripes) involved somewhere in the development. It does everything I want, and crucially, the migration process appears easy.

Under 11.6.1, Intaglio runs just ‘enough’ to open an existing document, and export it as .SVG (best with ‘embed images’ ticked if there is imported stuff). Graphic will then open this, and the only thing you have to do (and not always) is reset the scale; all your dimensions then come good. The user interface is OK (could be better, but could also be massively worse), and the screen layout (I found) could be made quite similar to (my implementation of) Intaglio. It has nice rulers (click and pull for guides), and the layers work well.

Its selection handles are a bit big & clunky, and it can do that irritating thing of moving an object 1 pixel when you click on it. It also lags slightly rendering off-screen portions of the document when you scroll (particularly if you have a fine grid showing). But that’s all I can really find against it, so far. These things are fairly forgivable, particularly as it also does pinch-to-zoom, which is quick — certainly than clicking the ‘big/small mountains’ buttons in Intaglio. And overall, the UI seems designed for grown-ups.

It’s a revelation, and a huge relief. The only thing which concerns me is that it hasn’t been updated for two years, so it’s entirely possible the whole ghastly episode could repeat. That’s why more people should know about it. For the money, it’s an absolute steal, and as an Intaglio replacement, it’s probably as good as it’s ever going to get.

Sorry to go on…

—Briar