JavaScript error

Hello everybody,
I’m having a problem with my website
For some time the two drop-down menus “Projects” and “About” are always “opened”, while when I test the preview in Freeway they are closed as they should be.
This happens with all the browsers, both with Mac and Windows.
Do you have an idea of what I may have touched/changed that creates this issue?
I see a couple of Safari warnings, but have no idea how to fix this, and know nothing about coding, http, https, JavaScripts warnings, etc…
I attach 3 pics

hoping to give you an idea of the problem.
Many thanks.

Adding to Luca’s report, the problem is caused by the fact that his site is attempting to load JavaScript libraries via an (insecure) http link. My guess is that he is using an old version of an Action (or an Action that is no longer supported) and I’ve suggested that he tries to track this down by progressively turning off Actions that are used on this page. The way that I would do this would be to duplicate the document (e.g. in the Finder) and remove most of the pages in the duplicate document, then use the Edit Actions dialog (in Freeway’s Edit menu) to turn off Actions until the error goes away. That should help to pinpoint which Action is outputting the http links.

The problem could have started when his site was upgraded from http to https. Alternatively, if he recently added another Action, it’s possible that this is causing the problem.

I’d guess that local preview works because it’s not using an https connection. So the easiest way to test this locally (after turning off Actions) would be to preview in a browser and see if the insecure links are being output at the top of the page source (just after <head>).

This problem was caused by the fact that the Transition FX Action outputs an insecure (http) link.

We’ve fixed this with a new version of the Scriptaculous Effects suite, which contains this Action:

Great! Thanks, Jeremy.