MP3 player question

I have several long mp3s on a site I’m building. I’m using the default QuickTime player, just dragging the files onto the page. Autoplay is on but here is the problem I’m having…

In Safari the QT player show up right away and the file begins to play when about 10% of the file is loaded. With IE on a PC it shows up a little slower but fairly quickly. In Firefox the QT player doesn’t show up until the entire file is downloaded, so the page appears to be not working. Some files have a 30 sec or so delay.

They are audio production demos, so I can’t reduce the quality any further (I’m using 192K mp3s)

Is there an Extended command that would force the player to show right away in Firefox?

http://www.jobecerny.com/wopnewtestament.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I have to add a new problem related to MP3 on a site that I am building now. All works fine in all the browsers except Google Chrom.

In Google Chrom all my MP3s are starting and playing at the same time or not showing at all. Is there any way to make them work normally?
See below :
http://testingmysiteonline.com/PatriciaCarr0512/

Just found this in GC:
https://support.google.com/chrome/bin/answer.py?hl=en&answer=1247383&p=ib_blocked_plugin

Blocked plug-ins
Plug-ins help browsers process special types of web content, like Flash or Windows Media files. Some plug-ins, such as Flash, are used by many websites on the Internet. Other plug-ins are only used by a small number of sites. Plug-ins are allowed by default. However, since they can occasionally be a security risk, Google Chrome blocks plug-ins that are outdated or those that are not widely used. Examples include Java, RealPlayer, QuickTime, Shockwave, Windows Media Player and Adobe Reader prior to Adobe Reader X. You can use the Content Settings dialog to block all plug-ins. When this happens, you will see a message such as the following:

“The Java plug-in needs your permission to run.”

You should only run the plug-in if you trust the website you are visiting (for example, your banking website might legitimately use a Java applet).

To let the plug-in run on the site, follow these steps:

To run the plug-in just this once, click Run this time in the message. The plug-in will run, but if you re-visit the site, you’ll be asked for permission to run the plug-in again.
To always allow the current site to run the plug-in, click Always run on this site. Subsequent visits to the site will run the plug-in without asking again.
To always allow this type of plug-in to run, go to chrome://plugins, find the plug-in and select the Always allowed checkbox.
Learn more about managing plug-ins

If you don’t want Google Chrome to ask your permission before running lesser-used plug-ins, use the command line flag --always-authorize-plugins. Instructions on how to add a command line flag can be found on our Chromium site:http://www.chromium.org/developers/how-tos/run-chromium-with-flags

I will give it a try.

Dan Demetriad


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

OK, bumping this back to the top.

I’ve been messing with this problem (my OP) on and off around other work and can’t seem to find an answer. Google searching HTML commands, I didn’t find anything that would force the player to show up in Firefox.

Any insight into why the player works fine in Safari, appears before the file is fully downloaded, and plays when the browser thinks there is enough streamed, but doesn’t show in Firefox would be greatly appreciated. I checked it in IE on a netbook and it seemed to work fine there also.

Stumped, Craig


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

So I finally got this working.

Turns out I wasn’t creating the mp3s “correctly”

I was exporting the mp3 files directly from Pro Tools where I was creating the demos. Apparently the header info is written in such a way that FF needs the whole file. Importing the WAV files of the audio demos into QT 7 and exporting as an AAC with “PREPARE FOR INTERNET STREAMING” selected was all that was needed.

Happy now, Craig


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options