Non functional (anymore) contact-form php-feedback action. Still not solved ...!


Having been since quite some time (years…) sitewise not Freeway Pro active anymore, I lately got an info. from someone who wanted to contact me through the website-contact form (PHP feedback form), that this does not work anymore : ( No idea, since how long, because we are rarely contacted over the website. Form did work before and I did not change anything.

Tested it myself and the message

Fatal error: Uncaught Error: Call to undefined function eregi() in /home/httpd/vhosts/ Stack trace: #0 {main} thrown in /home/httpd/vhosts/ on line 49

was displayed, similar on / for all three websites (built 2009. Installed I do have actually now Freeway Pro 7.1.4).

As suggested, I removed the action “php-feedback form” from this page and replaced it by the action “send form”.

But still the same message …!

Any real solution from someone to cure this problem once and for all?

Thanks and regards, Peter

This is going to be down to what version of PHP is installed on your server. Can you ask your hosting provider (or check the control panel) and see what’s running there?

A different solution would be to use an externally-hosted form handler, so you aren’t confined to what your hosts configure (and upgrade at their whim). Have a search for static site contact form handler or words to that effect. Here’s one result you might look at: 5 Ways to Handle Forms on Your Static Site |


Hi Walter
I checked that:
It is possible to choose from 7.3 and 7.4 (both marked as outdated) and 8.0, 8.1 and 8.2.
Chosen is right now 7.4.
But I think, question is, which PHP-version Freeway 7.1.4 supports? Could not find anywhere any info. on that (goooooogeling).
Thanks already for the quick reply.
Regards, Peter

Freeway doesn’t use PHP, but some Freeway Actions (including the Send Form Action) do. There is some information on the Send Form Action here. This says that it requires PHP 5.2 or above. There is also a newer version of the Send Form Action, but I don’t think it’s been updated to use a later version of PHP (unless @simonmanning can correct me on that).

That’s correct. I’m fairly sure the newer version didn’t change compatibility so both should work with PHP 7.4 but definitely neither will work with PHP 8.0 or later.

If the error message is the same, i.e. it contains Call to undefined function eregi(), it must still be using PHP Feedback Form as Send Form doesn’t use that PHP function. Could you have uploaded to the wrong location on your server or uploaded a different copy of the website which didn’t include the change?

Hello everybody.

I did change PHP yesterday to 8.2 (which did not make any difference) and today, according to Jeremys info. back again to 7.4.

Unfortunately no change with (actual status):

action php-feedback form removed
action send form added

Still the same error-message …

Might it be, that the upload does not work (anymore as well …)?

Tried to check that by adding some TEST-TEXT (which does not show online!) in the contact-form site and now I get an error-message JavaScript-error when uploading. According to the window “problems while generating”, this should be caused by the action Validate … (for the fields to be filled in).

It seems to me, that no changes at all are uploaded …!!!

To be honest, it it getting very annoying. Just nothing works with this programm anymore!!!

And after hours (again) I do not get a step further to a solution.

Freeway publishes a site before uploading it. The error that you describe sounds like an Action error that occurs during publishing rather than an upload error. Upload errors are reported in the Upload window. You can also look at a log file to see what has been uploaded (if the Save Log checkbox is turned on in the Upload dialog). The log file is saved in a Logs folder inside your user Library folder: you can get to the user Library folder by holding down the Option key and choosing Library from the Go menu in the Finder.

Well, the added text TESTFORM on the first line of the contact-form site (to see if it is changed online) is not published, checking the site in the browser (Firefox).

I therefore assume, that no changes at all made on the site are uploaded (also not the removal of the action php-form and not the added action send form)!

No idea why …!

Therefore also not possible, to check if action changes solved the send-problem …

You could use an FTP application (such as Cyberduck or Transmit) to check whether files have been uploaded, or you could look at Freeway’s FTP log file for a record of what has been uploaded.

However, one thing to be aware of is that if you are looking at your site in a browser, you may not see changes immediately. It is possible that the site is being cached by the browser, or by your internet provider. You can clear Safari caches for a particular page by holding down the Option key and choosing Reload Page From Origin from the View menu (the Firefox equivalent is to hold down the Shift key and press the Reload button). If the site is being cached upstream, you might have to wait (a day or so) for the caches to be updated.

When I upload the site, the window opening shows FTP, FTP-mode passiv.

Neither changes made yesterday nor today are shown. Also typed in web-address completely, checked as well in Safari. There are definitely no changes made at all uploaded …

The Library / Logs-folder does not show anything from Freeway at all … Search with / for Freeway log, no result.

Upload was so far never a problem. Now suddenly it is.

  1. Does the Upload progress window (the window that displays an upload progress bar) show any errors during or after uploading?

  2. Is the Save Log checkbox turned on in the Upload dialog? If it is, you should be able to find an FTP log inside a “Freeway Pro” folder in the “Logs” folder of your “Library” folder (using the Finder’s Go menu to locate the correct Library folder). However, it’s possible that if you are using an old version of Freeway (Freeway 5?) the log file may have been saved in a different location. In that case, an easy way to locate it would be to type “ftp.log” in the search bar of a Finder window.

  3. Have you tried using an FTP program to see if the files have been uploaded? I’m pretty sure there are free trial versions of Cyberduck and Transmit that you could use for this. These provide a Finder-like interface to your online location - you can use the same FTP details (user name, password etc.) that you use in Freeway.

There is no upload-progress window showing …

Only the window “problems when generating” with JavaScript error, parameter has no value, action can not be used.

You then have to press O.K. and that’ it. Nothing further happens.

It should be uploaded to the server of my provider as before. I especially changed the password in their Plesk. Used the same in the Freeway upload window. Still no upload!!!

I have no idea what I should do with a download of Cyberduck and how to use it … Sorry.

If you don’t see an upload progress window, that means that upload is not happening. If Freeway fails to publish a site, it won’t try to upload it. You probably can’t preview it in a browser, either. What happens if you choose Preview in Browser from the File menu?

So the next thing to do is to look at the error you get while publishing. Can you post a screenshot of this error? You can do this by pressing Command-Control-Shift-4 and selecting the error dialog on screen. This will copy an image of the screen to the clipboard, and you should then be able to paste it (Command-V) into your reply.

To use Cyberduck, choose Open Connection in the File menu, and enter the information that you use within Freeway. But we probably need to figure out the publish problem first.

[Edited to correct the screenshot shortcut (Control not Option)]