php feedback form

Hi all,

I’ve a problem with the PHP feedback form. In Safari, the webpage seems to be good, but when I open the page in FireFox The text and the fielts aren’t at the same hight. Any idea what went wrong?
You can visit the page at: www.picadesign.be/contact.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

This is unlikely to be a problem with the Action. Browser
interpretation of form field height varies, unless ‘pushed’ to a
specified size. Try putting all the form elements in a table and it
will keep things lined up. You can also try the Freeze Form Item
Action to control the depth of form items. You’ll find it at:

http://actionsforge.com/actions/view/64-freezeformaction

And if you want to get really fancy there’s Form Element Styler at:

http://actionsforge.com/actions/view/60-form-element-styler.

HTH Colin

On 1 Feb 2010, at 15:55, Bart wrote:

Hi all,

I’ve a problem with the PHP feedback form. In Safari, the webpage
seems to be good, but when I open the page in FireFox The text and
the fielts aren’t at the same hight. Any idea what went wrong?
You can visit the page at: www.picadesign.be/contact.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Collin,

Thanks for your advice. It’s working perfect now.

Bart


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I’ve tried the freeze form, seems to work in Safari, but not in the new Firefox 4.0. Also, in both browsers, you can still grab any of the fields bottom corner and resize the box to any size you want and all your formatting gets all out of whack. Can that be changed so that the viewer cannot grab that corner and resize it their hearts content? Thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Try this;

  1. Select the Text Area item you want to lock the size of and choose Item > Extended.
  2. Make sure the tab is selected and click on the New button.
  3. In the resulting dialog enter;
    name: style
    value: resize: none;
  4. Click OK, and OK again to get back to your document and you should be set.

You should notice that the Text Area can no longer be resized in the browser.
Regards,
Tim.

On 14 Apr 2011, at 09:22, RA wrote:

I’ve tried the freeze form, seems to work in Safari, but not in the new Firefox 4.0. Also, in both browsers, you can still grab any of the fields bottom corner and resize the box to any size you want and all your formatting gets all out of whack. Can that be changed so that the viewer cannot grab that corner and resize it their hearts content? Thanks.

FreewayActions.com - Freeware and commercial actions for Freeway Express & Pro.

Protect your mailto links from being harvested by spambots with Anti Spam.
Only available at FreewayActions.com

http://www.freewayactions.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

While Tim is absolutely correct, you might want to think more about
designing your form page so that changes like this don’t matter.

The browser manufacturers have spent tons of money and time on
providing this feature for your users, and they sincerely believe that
it is useful and good. I happen to agree with them.

A fully inline layout, either deliberately constructed or by dint of
the excellent RPL Action, will give you a page where resized elements
will look good and natural. And in any case, when designing a form in
Freeway, you should (for semantic reasons and for the good of visually-
disabled persons everywhere) put your form elements in a two (or more)
column table. Otherwise, the “labels” you make have little or no
semantic connection to the form fields that they (only visually) abut.

Walter

On Apr 14, 2011, at 5:12 AM, Tim Plumb wrote:

Try this;

  1. Select the Text Area item you want to lock the size of and choose
    Item > Extended.
  2. Make sure the tab is selected and click on the New
    button.
  3. In the resulting dialog enter;
    name: style
    value: resize: none;
  4. Click OK, and OK again to get back to your document and you
    should be set.

You should notice that the Text Area can no longer be resized in the
browser.
Regards,
Tim.

On 14 Apr 2011, at 09:22, RA wrote:

I’ve tried the freeze form, seems to work in Safari, but not in the
new Firefox 4.0. Also, in both browsers, you can still grab any of
the fields bottom corner and resize the box to any size you want
and all your formatting gets all out of whack. Can that be changed
so that the viewer cannot grab that corner and resize it their
hearts content? Thanks.

FreewayActions.com - Freeware and commercial actions for Freeway
Express & Pro.

Protect your mailto links from being harvested by spambots with Anti
Spam.
Only available at FreewayActions.com

http://www.freewayactions.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you Tim, thank you Walt. I will do the RPL and yes I have them in a table. Thank you so much for all your help. I’m new to FWP and I really love this thing.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

If they are in a table already then resizing a text area should not affect the other form elements.

Did you click inside the cell until you get a flashing cursor and use Insert>Form Items?

If you just drew them on the page they may not be part of the table at all.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 14 Apr 2011, 7:59 pm, DeltaDave wrote:

If they are in a table already then resizing a text area should not affect the other form elements.

Did you click inside the cell until you get a flashing cursor and use Insert>Form Items?

If you just drew them on the page they may not be part of the table at all.

David

I’m pretty sure I did it that way. When I get back I’ll double check or redo them. Thank you. :slight_smile:


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sorry - I didn’t realise there was a link to your page.

Wow! What a construction.

There is an individual Div for every dot that underlines your Nav items. You can draw a dotted line to avoid this.

As to the resized text area - I see increasing its size does not affect the other form elements - just the frog and the footer. So use RPL and it should sort that.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 14 Apr 2011, 8:52 pm, DeltaDave wrote:

Sorry - I didn’t realise there was a link to your page.

Wow! What a construction.

There is an individual Div for every dot that underlines your Nav items. You can draw a dotted line to avoid this.

As to the resized text area - I see increasing its size does not affect the other form elements - just the frog and the footer. So use RPL and it should sort that.

D

Okay, Wow as in crazy wrong? lol It’s only a few weeks in FW so forgive my screw up. :wink:

I think I got it on the forms. I didn’t realize to check the code itself after uploading.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

How did you create the dotted underlines for the nav links?

If you used the CSS Menu action you could set a custom border of a dotted line and simplify your layout.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 14 Apr 2011, 10:08 pm, DeltaDave wrote:

How did you create the dotted underlines for the nav links?

If you used the CSS Menu action you could set a custom border of a dotted line and simplify your layout.

D

I did use the CSS Menu Action. As I typed out my list, I then highlighted each Menu and selected the hyperlink. I then checked the CSS Action and turned off a pretty much all borders. Checked on underline hover… Everything else is off or unchecking in regards to border and background.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options