PHP Mark Up

Hi,
I use the Freeway action PHP Mark UP on a page to add PHP code.

If enter a simple line such as $to=“email@hidden”; Freeway converts this to something like $to=‘■■■■■■■’; which actually fails on the server I"m hosting this on.

Is there anything I can do to stop Freeway converting this? I understand these are just ASCII codes, but the fact that it’s failing (server error) means I need to find a fix. If I manually change the php file and FTP up it works fine.

Thanks,

John


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Oops - stupid me - I think I found the answer in document setup - Email hiding, code with entities.

Removing this seems to make it work.

Sorry folks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 7/1/09 (at 07:59 -0500) johnrob said:

I use the Freeway action PHP Mark UP on a page to add PHP code.

If enter a simple line such as $to=“email@hidden”; Freeway
converts this to something like
$to=‘■■■■■■■’;

Have you wrapped the code in the opening and closing PHP tags? This
may be a dumb question - I use regular markup items rather than
actions to drop nuggests of PHP code into my Freeway pages, and I
can’t remember what that action requires.

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I use the Markup item for adding php on all if not most of my sites
and do not seem to have a problem with this, the code shows as
$to=‘■■■■■■■’; on the page code created
by FW but it looks like it should on the page even if set using a PHP
variable. My preferences are set to ‘Encode with entities’.

What is the problem you are actually having with this?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

johnrob, I see you where talking about the PHP mark-up action, read
the email too quickly I guess and thought you where talking about
using mark-up… sorry :slight_smile:

On Jan 7, 2009, at 2:39 PM, Mike B wrote:

I use the Markup item for adding php on all if not most of my sites
and do not seem to have a problem with this, the code shows as
$to=‘■■■■■■■’; on the page code
created by FW but it looks like it should on the page even if set
using a PHP variable. My preferences are set to ‘Encode with
entities’.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options