Pictures in Exhibeo slideshow muddled up

I’m experimenting with the different Exhibeo slideshows, Photoswipe being the one I prefer had it not for its strange behaviour. It works fine in Safari only, while in Chrome, Firefox and Opera (and others?) the pictures are muddled up and large spaces appear. This is it, third slideshow down: Travels
I think I had a similar problem in Freeway back in the day, but unfortunately can’t remember how it was solved. I even asked the Freeway forum for help.
I’ve tried different ways both inside Xway and inside Exhibeo to no avail, so any suggestions will be welcome.

Hi Jon,

I can see there are spaces when I look at your page in Firefox, but I haven’t been able to recreate this by downloading your images and creating my own Photoswipe gallery.

If you send us a copy of your Exhibeo gallery (via support at softpress dot com) I can take another look!

Probably the best way to save a copy is to choose Save Archive from the File menu in Exhibeo.

I got your files, thanks!

Curiously, I still don’t have a problem, although I’ve tried applying the same styles that I see are applied on your web page.

My next question is: does the problem happen if you preview with Firefox (etc.) locally? Xway doesn’t have an option to preview in non-default browsers (yet) but you can do this by previewing in Safari and copy/pasting the link from Safari’s URL field into Firefox’s URL field.

It might be helpful if you can also end me your Xway document, or a cut-down version.

A few comments on your webpage generally:

  1. You have used “main” items for the galleries, but you should try to avoid having more than one “main” item on a page (w3c recommendation - also mentioned in the Xway User Guide ). I’d suggest converting the Main items to Section items (Type popup in the Box Inspector).

  2. The Photoswipe component has a minimum height of 0. If you don’t need a minimum height (as here), it’s better to delete it (in Xway) than set it to zero.

  3. You don’t need to centre the component if you’ve set the width to be 100% (there’s no space left over to centre it within). You can remove the centring by choosing Unaligned in the Align popup (in the Margins and Alignment section of the Box Inspector).

  4. You’ve also set the component to have a font size of Large and a line height of 0.7. I’m not sure if these are needed for any reason. If they’re not needed, you can just delete them (Xway will then show the default values, which it doesn’t need to output).

Hi Jon,

Thanks for the Xway document!

What seems to be causing this problem is that you have widened the letter spacing on the master page from which this page is derived. This seems to be causing some kind of calculation error in the Photoswipe gallery. I’ll log this as a bug in Exhibeo.

You can fix this problem in Xway by resetting the letter spacing for the Photoswipe gallery:

  1. Select the gallery
  2. Open the Text section in the Box Inspector
  3. Change Letter Spacing from 0.3em to 0em

I see you have moved us to the Exhibeo forum. Fine with me. I just thought the Xway forum had a bigger audience and thus more chance of getting responses as I didn’t know if it was an Exhibeo or Xway related problem.

Thank you for solving it. Now it works beautifully. I would never have thought of that solution. I also changed the boxes into Section as you adviced. At the moment I do the experimenting and will properly name all items in due course.

I quite like the Bloxx gallery, too (Bottom gallery, Travels). However, I don’t like the “jumping down and in” effect when selected. Is there a way of tweaking Exhibeo to do other things? Like a fade in, for example? And is there a way of getting the picture big, as in the slide gallery?

Kind regards,

…with regards to number 4 the components are set to size 2em and line height normal in the text section. When I try to remove these values it is not possible. I also tried to uncheck the use master style box.

I wasn’t sure if it was an Xway or Exhibeo issue when you first posted, but I changed the category because it is essentially an Exhibeo issue, so it could also affect people using Photoswipe with Freeway or HTML export.

I don’t think the initial bouncing can be changed, unless @simonmanning has a suggestion. Fading would be a nice alternative. The size of the thumbnail can be tweaked in Customize Theme (Document Settings > Thumbnail Scale). The Focus theme is similar in some ways, so might be an alternative.

You can’t remove the values entirely, because text always has a size and the Inspector will show the current default/inherited value if it hasn’t been specifically defined (as it was previously).

Thank you. Unfortunately nothing changes in the Customize Theme Document Settings when set at max (200%. 200% of what by the way?). I thought there could be a work around to get the thumbnail to 100% of page width somehow?

A little off topic: When I open both Xway and Exhibeo I’m presented with a blank page as to start a new project which can be quite tiresome when I go in and out with a project I’m working on. Also, when closing even if I have done nothing I’m asked to save or not. Also quite tiresome. Could this be a thing to reconsider?


200% of the default size, i.e. twice as wide and twice as high (it works for me). I don’t think you can make it larger than this. Note that it also changes the size of the thumbnails that appear after the gallery is opened.

Being asked to save when closing a document is a general Mac behaviour which you can modify via checkboxes in System Settings > General (Ask to keep changes when closing documents and Close windows when quitting an app). Previewing in Xway changes a document, because the HTML files are republished (we’re planning to change this in future - by not replacing HTML files if they haven’t changed). If you want Xway/Exhibeo/other applications to reopen the same windows after quitting and restarting, you can deselect the Close windows when quitting an app checkbox. Another option is to launch Exhibeo or Xway (or other applications) by double-clicking on the document you wish to open.