[Pro] 1st steps into FW7

FW forum

Hi

I have just upgraded from Express to Pro 7 and am going through the Extended Reference for FW7. I have to add that it is many years since I built my crude little web site with FW Express, so I have to re-learn FW from scratch, not only the new achievements.

Some of my first experiences:
1-
When I open FW7, either a blank template or the supplied ‘Clouds’, and go to the Help menu, I am directed to the Mac Help! However, if memory serves me, the first time I tried, I came to an FW fly-out menu, which let me directly open items in FW. Some prefs seem to be corrupted. What can I do? Mac OS 10.11.6

2-
A note on terminology: Reference p 2, left column near bottom:
“…choose Center in the Align popup in the Inspectors General Settings tab…”
It took me some time to find this ‘popup’. I am not a native speaker of English, but a long time Mac user, and I think this kind of thing is normally called a drop-down menu: you click it, or a disclosure triangle at left, and it reveals its menu items, of which then you can choose one. A popup, otoh, is something that pops up when you mouse over an item, normally an explanative text. Like those over the icons in the top bar of the Inspector window.

3-
Reference p 8: The Responsive section: I am unable to find that menu. An ‘Actions’ item appears in various menus. Maybe this is the panel evoked by Window > Actions. Maybe in my case it was empty because the page was empty. But when I open the ‘Clouds’ template and select one of the Master Pages, the Actions panel shows a tab 'Auto Clearfix (FW 7)'and 2 menu items: ‘Enable’ and ‘Apply to all unfloated elements?’. No disclosure triangle. Can you guide me to that menu?

Best regards - Hening


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Hening

Some of my first experiences:
1-
When I open FW7, either a blank template or the supplied ‘Clouds’, and go to the Help menu, I am directed to the Mac Help! However, if memory serves me, the first time I tried, I came to an FW fly-out menu, which let me directly open items in FW. Some prefs seem to be corrupted. What can I do? Mac OS 10.11.6

You should see a search field followed by some Freeway shortcuts (“Welcome to Freeway” etc.). There aren’t any preferences for the Help menu, so I don’t think your preferences are corrupted.

2-
A note on terminology: Reference p 2, left column near bottom:
“…choose Center in the Align popup in the Inspectors General Settings tab…”
It took me some time to find this ‘popup’. I am not a native speaker of English, but a long time Mac user, and I think this kind of thing is normally called a drop-down menu: you click it, or a disclosure triangle at left, and it reveals its menu items, of which then you can choose one. A popup, otoh, is something that pops up when you mouse over an item, normally an explanative text. Like those over the icons in the top bar of the Inspector window.

A drop-down menu is one that drops down (like menus in the menu bar). This menu really is called a popup menu (and the control that displays it is known as a popup button) because it pops up. We’re using “popup” as an abbreviation of “popup menu” or “popup button" but there could be other kinds of popups, as you describe.

3-
Reference p 8: The Responsive section: I am unable to find that menu. An ‘Actions’ item appears in various menus. Maybe this is the panel evoked by Window > Actions. Maybe in my case it was empty because the page was empty. But when I open the ‘Clouds’ template and select one of the Master Pages, the Actions panel shows a tab 'Auto Clearfix (FW 7)'and 2 menu items: ‘Enable’ and ‘Apply to all unfloated elements?’. No disclosure triangle. Can you guide me to that menu?

The “Responsive” section is part of the UI for the CSS Menus Action. The Actions palette (which you’ve found in the Windows menu) is contextual: it displays settings for Actions that are applied to the currently selected page or item. If you select an item that uses the CSS Menus Action, you should see this section near the bottom of the palette.

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thank you Jeremy.

Concerning the Help menu:

You should see a search field followed by some Freeway shortcuts (“Welcome to Freeway” etc.).

Yes I do. But if I enter anything in the search field, the Freeway shortcuts are replaced by entries in the Apple Mac Help. Eg if I enter ‘pass through’, the first entry says ‘Trace the paths of your network traffic’, and the title bar of the new window that opens says ‘Mac Help’.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Hening,

But if I enter anything in the search field, the Freeway shortcuts are replaced by entries in the Apple Mac Help. Eg if I enter ‘pass through’, the first entry says ‘Trace the paths of your network traffic’, and the title bar of the new window that opens says 'Mac Help’.

I think that’s just the way that the Help menu works, in Freeway and in other programs. The Search part of this menu belongs to macOS rather than Freeway. If you type here, macOS will look for matching menu items (in Freeway) or for matching help topics that are in Apple Help format. Freeway’s documentation is in PDF format (rather than Apple Help format), so the Help menu doesn’t find topics there - but you can open the documentation and search for phrases. To find out about pass-through (passthrough) graphics, search for “passthrough”.

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

My first page

1-
In the master page, I have set the Default page size to 1200x980 px. That is about the pixel count of my 19" sreen. Then, when I choose the start page and choose ‘Use master settings’ in the page panel, a frame is shown that shows these borders. But beyond them there is a stripe of about 80 px at right and about 45 px at bottom, that also shows the background color I have chosen for the page.

If I select one of the items on the page and move it a little, that frame snaps to the outside of that larger area.

Both the master and the page show the same numbers in the Measurement panel.

What is this?

And also, if I deselect ‘Use master settings’ again, the frame does not go away again. ?

2-
The page contains 2 text fields, and an image as pass-through graphic. When I set the Width and Height of that graphic to ‘Fixed’, it is just that: If I open it in a browser and diminish the window, the image is cut at right.
If otoh I set the size to ‘Fixed %’, it scales with the browser window - but also with that windows aspect ratio. The latter is not the meaning. Is there a way to avoid this and still have the image adapt to the browser size?

To try that, I set the size to ‘Flexible’. The image was downsized to about 1/2, and the box frame shrunk to the new size. And it stays that way also after I set the size to ‘Fixed’ again. Even after I deleted the content, enlarged the box, set the Measurements to ‘Fixed’ again and re-imported the image. The Measurement snapped to 'Flexible again. (How) can I revert that? And what is going on here?

3-
If I import the image as pass-through graphic, FW forces me to ignore the resolution. In the Import dialog, the resolution is reduced from 176 to 169 ppi. Well, no big deal. But why?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

In the master page, I have set the Default page size to 1200x980 px. That is about the pixel count of my 19" sreen. Then, when I choose the start page and choose ‘Use master settings’ in the page panel, a frame is shown that shows these borders. But beyond them there is a stripe of about 80 px at right and about 45 px at bottom, that also shows the background color I have chosen for the page.

There is an area known as the “pasteboard” that is outside the page area. This displays the background colour you’ve chosen for the window (“window background”).

If I select one of the items on the page and move it a little, that frame snaps to the outside of that larger area.

There are some options in "Preferences/Grids & Guides” that control the magnetic (snapping) range of grids and guides. Do you have a grid or some guides on the page?

And also, if I deselect ‘Use master settings’ again, the frame does not go away again. ?

Items are part of the page’s content, so they’re affected by Use Master Content rather than Use Master Settings. However, turning Use Master Content off won’t automatically remove items that come from the master page.

The page contains 2 text fields, and an image as pass-through graphic. When I set the Width and Height of that graphic to ‘Fixed’, it is just that: If I open it in a browser and diminish the window, the image is cut at right.
If otoh I set the size to ‘Fixed %’, it scales with the browser window - but also with that windows aspect ratio. The latter is not the meaning. Is there a way to avoid this and still have the image adapt to the browser size?

If you want an image to keep its aspect ratio when the window is resized, what you need to do is to set the width of the image to be a percentage value, but leave the height undefined. If you define both, both will scale with the window size. If you only define the width, the width will scale with the window width and the height will scale with the width.

If I import the image as pass-through graphic, FW forces me to ignore the resolution. In the Import dialog, the resolution is reduced from 176 to 169 ppi. Well, no big deal. But why?

“Ignore Resolution” really means “display the image as if it is a screen-resolution image” (ignoring any resolution that is stored in the image). With non-passthrough images, Freeway normally takes the resolution into account, so that a 300x300 dpi image will be the same screen size as a 72x72 dpi image (1 inch square).

Does the Import dialog display resolution somewhere? The figure next to the “Pass-through” checkbox is the file size rather than the resolution.

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thank you Jeremy. I’ll now study your answer in more detail.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

FW 17 dec

I’ll focus on the image size for now.

If you want an image to keep its aspect ratio when the window is resized, what you need to do is to set the width of the image to be a percentage value, but leave the height undefined.

Hm. How can I do that? In the Measurement pane, the choices are Fixed-Fixed%-Flexible-Minimum-Minimum%-Stretchy. No Undefined. In the Dimensions pane, there is a Height field, which seems to show the current value. If I clear it, then close and re-open the pane, it has snapped back to that same value. ??


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

If you want an image to keep its aspect ratio when the window is resized, what you need to do is to set the width of the image to be a percentage value, but leave the height undefined.

Hm. How can I do that? In the Measurement pane, the choices are Fixed-Fixed%-Flexible-Minimum-Minimum%-Stretchy. No Undefined. In the Dimensions pane, there is a Height field, which seems to show the current value. If I clear it, then close and re-open the pane, it has snapped back to that same value. ??

In the Measurements pane, “Flexible” is the same as undefined. Items with undefined height grow or shrink (flexibly) to fit their content.

In the Dimensions pane, a dimension is undefined if the button next to the field is unselected. The field shows the actual height (as displayed within Freeway) but you can’t edit this value - it’s greyed out to show that it’s really undefined.

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

If you want an image to keep its aspect ratio when the window is resized, what you need to do is to set the width of the image to be a percentage value, but leave the height undefined.

Wow! That works! Thank you.

Now is there a choice to achieve that the fields on the page stay centered if the size of the browser window is changed? I tried various combinations of the H and V Align menus, but with no luck.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Oh I just see this should be possible to do by using frames. I’ll have to study that in more detail.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Now is there a choice to achieve that the fields on the page stay centered if the size of the browser window is changed? I tried various combinations of the H and V Align menus, but with no luck.

If you want to centre an image horizontally, the best way to do that is to use an inline image and set the text alignment (in the Text panel of the Inspector palette) to be centred.

Oh I just see this should be possible to do by using frames. I’ll have to study that in more detail.

Don’t use frames (Frames option at the bottom of the Page menu). They’re an old HTML feature that has been more or less discarded. I think the reason they still exist in Freeway is as a legacy feature.

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thanks.
I remember from my 1st encounter with FW that i-frames were a smart replacement. On the download page for the iFrame action I read that it works up to FW Pro 6, but not 7. Is this up to date info?
And would iFrames indeed enable me to do what I want?

By the way, the link ‘For usage see’ does not work.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I remember from my 1st encounter with FW that i-frames were a smart replacement. On the download page for the iFrame action I read that it works up to FW Pro 6, but not 7. Is this up to date info?

iframes are OK, and I don’t think there are any problems using the iFrame Action with Freeway 7 (see Walter’s comment there).

And would iFrames indeed enable me to do what I want?

I wouldn’t personally use iframes as a layout tool. There are easy ways to centre content horizontally. Do you also need to centre vertically?

By the way, the link ‘For usage see’ does not work.

It should probably be:

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

There are easy ways to centre content horizontally.

Please tell me. The Reference shows no returns when searched for ‘centre’.

Do you also need to centre vertically?

Not sure yet if that is as necessary as horizontally. I could image it might result in fields overlapping each other. But if that can be avoided, it sounds like it would be nice, too.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

There are easy ways to centre content horizontally.

Please tell me.

  1. Inflow box: insert an HTML box at a text cursor and choose “Center” from the Align popup in the Measurements section.

  2. Inline image: insert a graphic at a text cursor and choose the Center Align button in the Paragraph section of the Text pane of the Inspector palette.

The Reference shows no returns when searched for 'centre’.

Freeway and its documentation are localised in American English - you need to search for “center” rather than “centre".

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thank you. I’ll try this.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

How can I do that? It sounds like I need a text cursor on the page background directly. The only way in which I can see a text cursor is inside an HTML box. So I would need an HTML field that covers the whole page? But even if I make such one, then draw a new (HTML) item in the top left corner (at the text cursor), there is no Center command in the Align menu. There is one called Middle, but regardless which one I choose, the new box does not move inside the first one.
I can’t find anything about this in the 28 pages that the search for ‘center’ returns in the Reference.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

You can double-click the page itself, which gives you a text cursor inside the page itself. However, this is the first step toward building a fully inline layout, and if you already have a lot of content on the page, it will be a learning curve and a bit of work in order to get the existing replicated in an inline setting.

If you already have a number of positioned (not inline) elements on the page, getting them to respect the elements that you add to the page itself as inline children will require you to make those positioned elements also inline. Imagine the stacked panes of glass in an animation stand, such as the ones used at Disney to make cartoons. (Well, they use computers now, but imagine nonetheless.) The inline elements are all together in the bottom-most layer. Any positioned elements you add above that are each on their own pane of glass, and no matter how they move, they will never bump into or displace any other elements on the page.

The benefit to a fully inline page is that you can make it rearrange naturally when the browser window is resized, or when the font size is changed by the user to accommodate their vision.

Walter

On Dec 18, 2018, at 8:54 AM, Hening email@hidden wrote:

How can I do that? It sounds like I need a text cursor on the page background directly. The only way in which I can see a text cursor is inside an HTML box. So I would need an HTML field that covers the whole page? But even if I make such one, then draw a new (HTML) item in the top left corner (at the text cursor), there is no Center command in the Align menu. There is one called Middle, but regardless which one I choose, the new box does not move inside the first one.
I can’t find anything about this in the 28 pages that the search for ‘center’ returns in the Reference.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thank you Walter. I’ll try this. I don’t have more than 3 items on my first and hitherto only page, so no problem building it all from scratch.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options