[Pro] adding custom HTML problem

Hi Folks. I am trying to add the following html to the top of my pages:
html {
background-color:#e1e1e1;
}

body {
background-color:#fff;
width: 1000px;
height: 850px;
margin-top: 20px;
margin-left: auto;
margin-right: auto;
padding: 15px;
}

So that I get a grey bg with the content in a white box (Can’t go back and rebuild whole site inside items) but no matter where I add it using the ‘markup’ dialog, it never ends up in the right place to work so I am having to hand code it to every page each time I export the site folder. How can I get this to work in Freeway, so it gets saved with the job?
cheers
Roger


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Are you sure you’re putting this code into a style tag?

<style type="text/css">

/* your code here */

</style>

If you do, this should just work. I would put it in the before /head
section. You might also want to fiddle with adding the !important
keyword to your body background color, in case Freeway has inlined
that style in the body tag itself.

background-color: #fff !important;

That should override anything else on the page.

If that doesn’t work, try setting it as

background: #fff;

instead of background-color, and see if that takes precedence.

Walter

On Mar 18, 2011, at 1:20 PM, Roger Harris wrote:

Hi Folks. I am trying to add the following html to the top of my
pages:
html {
background-color:#e1e1e1;
}

body {
background-color:#fff;
width: 1000px;
height: 850px;
margin-top: 20px;
margin-left: auto;
margin-right: auto;
padding: 15px;
}

So that I get a grey bg with the content in a white box (Can’t go
back and rebuild whole site inside items) but no matter where I add
it using the ‘markup’ dialog, it never ends up in the right place to
work so I am having to hand code it to every page each time I export
the site folder. How can I get this to work in Freeway, so it gets
saved with the job?
cheers
Roger


freewaytalk mailing list
email@hidden
Update your subscriptions at:
List Options | FreewayTalk


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Walter,

Yep, that worked perfectly. I didn’t put it within a style tag. I’m not to hot on html coding I’m afraid!

Many thanks for your help it’s saved me hours…

Roger


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options