[Pro] Cannot complete upload

Attempting to initiate an upload results in Freeway issuing the following warning: “Cannot complete upload because the peer certificate could not be authenticated with known CA certificates.” What causes this? Anyone have a solution?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Cannot complete upload because the peer certificate could not be authenticated with known CA certificates.

What upload Schema are you using? If you are using FTPS try straight FTP

This is usually because your Server certification is hicky - straight FTP doesn’t check it.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I was using FTPS, so I tried FTP. Same result (no upload), but different warning: “Sorry, cleartext sessions are not accepted on this server.”

Bob

On 31 Dec 2015, 5:32 pm, btownbob wrote:

Attempting to initiate an upload results in Freeway issuing the following warning: “Cannot complete upload because the peer certificate could not be authenticated with known CA certificates.” What causes this? Anyone have a solution?

On 31 Dec 2015, 5:46 pm, DeltaDave wrote:

Cannot complete upload because the peer certificate could not be authenticated with known CA certificates.

What upload Schema are you using? If you are using FTPS try straight FTP

This is usually because your Server certification is hicky - straight FTP doesn’t check it.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Same result (no upload), but different warning: “Sorry, cleartext sessions are not accepted on this server.”

Then you need to speak top your hosting provider and ask if there are any specific upload requirements/settings.

Who hosts your site? - others hosted there may have some insights.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

One thing to try is to upload to the server host’s name, not your own domain. They very likely will have given you instructions to upload into your account when you signed up for hosting, and the SSL key may be set for the abc-hosting.com domain rather than the your-domain.com that you are uploading to (if that’s what you are doing).

Walter

On Dec 31, 2015, at 3:02 PM, DeltaDave email@hidden wrote:

Same result (no upload), but different warning: “Sorry, cleartext sessions are not accepted on this server.”

Then you need to speak top your hosting provider and ask if there are any specific upload requirements/settings.

Who hosts your site? - others hosted there may have some insights.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

First, thanks David and Walter for your assistance.

I have contacted Aabaco Small Business support (formerly Yahoo Small Business. After a 15 minute discussion, their solution was to use an FTP client separate from Freeway. Not my choice, since FTP with Freeway makes uploading/updating very easy.

I’ve tried both of your suggestions to no avail. Using an FTP client named “Fetch”, I am able to upload/download files. HOWEVER, Fetch does throw up a warning about an expired certificate. Fetch allows me to by-pass the warning and continue.

It seems I have two solutions:

[1] Is there a way within the Freeway FTP mechanism to bypass the certificate issue? (preferred)

[2] I can Upload using File Copy to a local folder and then use Fetch to upload everything to the recalcitrant server, right? As long as I link other websites/pages to the “index.html” in the folder, all should work? (not preferred, since updating/uploading will require more steps)

Your thoughts?

– Wishing you a very Happy New Year
– Bob


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

HOWEVER, Fetch does throw up a warning about an expired certificate.

If there is an expired certificate then you should speak to your hosting provider about getting it renewed so that you can go back to using FW (or Fetch without any warnings).

The second method is a workaround that does require far more effort than necessary.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I will contact them about renewing the certificate.

Thanks again …

– Bob


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Have you tried switching the passive/active FTP setting in Freeway? It often helps in these situations, I’ve had those issues as well with a couple of clients.

Richard


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Richard –
Yes, switching the FTP setting was the first thing I tried. Until Aabaco renews the expired certificate, I’m resorting to a non-Freeway FTP upload. In some cases, I’m able to identify the specific file that needs to be updated, which saves a lot of upload time. It makes me appreciate the ease of use with Freeway even more.
– Bob

On 31 Dec 2015, 5:32 pm, btownbob wrote:

Attempting to initiate an upload results in Freeway issuing the following warning: “Cannot complete upload because the peer certificate could not be authenticated with known CA certificates.” What causes this? Anyone have a solution?

On 31 Dec 2015, 5:46 pm, DeltaDave wrote:

Cannot complete upload because the peer certificate could not be authenticated with known CA certificates.

What upload Schema are you using? If you are using FTPS try straight FTP

This is usually because your Server certification is hicky - straight FTP doesn’t check it.

David

On 31 Dec 2015, 6:24 pm, btownbob wrote:

I was using FTPS, so I tried FTP. Same result (no upload), but different warning: “Sorry, cleartext sessions are not accepted on this server.”

Bob

On 31 Dec 2015, 5:32 pm, btownbob wrote:

Attempting to initiate an upload results in Freeway issuing the following warning: “Cannot complete upload because the peer certificate could not be authenticated with known CA certificates.” What causes this? Anyone have a solution?

On 31 Dec 2015, 5:46 pm, DeltaDave wrote:

Cannot complete upload because the peer certificate could not be authenticated with known CA certificates.

What upload Schema are you using? If you are using FTPS try straight FTP

This is usually because your Server certification is hicky - straight FTP doesn’t check it.

David

On 31 Dec 2015, 8:02 pm, DeltaDave wrote:

Same result (no upload), but different warning: “Sorry, cleartext sessions are not accepted on this server.”

Then you need to speak top your hosting provider and ask if there are any specific upload requirements/settings.

Who hosts your site? - others hosted there may have some insights.

D

One thing to try is to upload to the server host’s name, not your own domain. They very likely will have given you instructions to upload into your account when you signed up for hosting, and the SSL key may be set for the abc-hosting.com domain rather than the your-domain.com that you are uploading to (if that’s what you are doing).

Walter

On Dec 31, 2015, at 3:02 PM, DeltaDave wrote:

Same result (no upload), but different warning: “Sorry, cleartext sessions are not accepted on this server.”

Then you need to speak top your hosting provider and ask if there are any specific upload requirements/settings.

Who hosts your site? - others hosted there may have some insights.

D

On 3 Jan 2016, 1:51 am, btownbob wrote:

First, thanks David and Walter for your assistance.

I have contacted Aabaco Small Business support (formerly Yahoo Small Business. After a 15 minute discussion, their solution was to use an FTP client separate from Freeway. Not my choice, since FTP with Freeway makes uploading/updating very easy.

I’ve tried both of your suggestions to no avail. Using an FTP client named “Fetch”, I am able to upload/download files. HOWEVER, Fetch does throw up a warning about an expired certificate. Fetch allows me to by-pass the warning and continue.

It seems I have two solutions:

[1] Is there a way within the Freeway FTP mechanism to bypass the certificate issue? (preferred)

[2] I can Upload using File Copy to a local folder and then use Fetch to upload everything to the recalcitrant server, right? As long as I link other websites/pages to the “index.html” in the folder, all should work? (not preferred, since updating/uploading will require more steps)

Your thoughts?

– Wishing you a very Happy New Year
– Bob

On 3 Jan 2016, 1:56 am, DeltaDave wrote:

HOWEVER, Fetch does throw up a warning about an expired certificate.

If there is an expired certificate then you should speak to your hosting provider about getting it renewed so that you can go back to using FW (or Fetch without any warnings).

The second method is a workaround that does require far more effort than necessary.

D

On 3 Jan 2016, 2:07 am, btownbob wrote:

I will contact them about renewing the certificate.

Thanks again …

– Bob

On 3 Jan 2016, 6:33 pm, Richard van Heukelum wrote:

Have you tried switching the passive/active FTP setting in Freeway? It often helps in these situations, I’ve had those issues as well with a couple of clients.

Richard


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

On 3 Jan 2016, 11:34 pm, btownbob wrote:

Richard –
Yes, switching the FTP setting was the first thing I tried.
– Bob

On 3 Jan 2016, 6:33 pm, Richard van Heukelum wrote:

Have you tried switching the passive/active FTP setting in Freeway?

Richard

Ah okay. I was asking you this because switching FTP Mode between Passive, Active and Automatic wasn’t mentioned in this discussion, while switching between FTP and SFTP protocols was.

Richard


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

On 4 Jan 2016, 10:43 am, Richard van Heukelum wrote:

On 3 Jan 2016, 11:34 pm, btownbob wrote:

Richard –
Yes, switching the FTP setting was the first thing I tried.
– Bob

On 3 Jan 2016, 6:33 pm, Richard van Heukelum wrote:

Have you tried switching the passive/active FTP setting in Freeway?

Richard

Ah okay. I was asking you this because switching FTP Mode between Passive, Active and Automatic wasn’t mentioned in this discussion, while switching between FTP and SFTP protocols was.

Richard

I had Freeway uploading problems, too, until I switched to Passive uploading. Then it worked fine. Might be worth one more try, using Passive.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options