[Pro] Caxton and fontnames

I use the Caxton action with a fontsquirrel generated webfont. The name of the font is made with underscores like this: Sinkin_Sans_Light.

The font is installed in my Mac too and the screen font name is Sinkin Sans light (no underscores) Does anyone know how to use these names in the font set? My font set name has the underscores in it, just as the name of the font under alternative fonts. The screen font is based on the fontname as in the system: without the underscores. What is good practice?
One thing: if I change the fontname in alternative fonts, to the screenname, then my webfont is not displayed!!

http://www.appadvies.nl


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Eitje, Wim :slight_smile:

  • Open up the css file and copy the complete name, including the ‘’ (probably ‘Sinkin_Sans_Light’ or something like that)
  • Go to Menubar > Edit > Font Sets
  • Create a new fontset with the copied name, including the ‘’
  • For screen font, select the installed font
  • Assign alternate fonts if you want to (I never do)
  • Done

Richard


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 15 Jan 2015, 4:40 pm, Wimdg wrote:
One thing: if I change the fontname in alternative fonts, to the screenname, then my webfont is not displayed!!

Nope. So don’t.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Richard,

So then the screen font is different from the other two in font set screen?
That’s the case with me now and someone from Softpress advised me to have the same screen font name and alternative font name.
And changing the alternative name messed up things. So you leave the alternative fonts empty?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The screen font just is the font loaded in OSX that represents the @fontface you assign it to. Would be nice if those two are the same, right? :wink: The screen font is just there for viewing purposes only.

So … the font has a ‘CSS’ name, and a ‘system’ name, that’s all.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

On 15 Jan 2015, 6:34 pm, Wimdg wrote:
So you leave the alternative fonts empty?

You could, but also could copy-and-pase the exact same name you assigned in the first field, just to be sure.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Richard,

OK right. Then I don’t know why Softpress says this procedure is not correct. But just to sure: you keep the ’ around the font name like:
‘Sinkin_Sans_Light’ ?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

you keep the ’ around the font name like: ‘Sinkin_Sans_Light’ ?

To be precise - if your Font name was slinky spider it would require apostrophes ‘slinky spider’ as it is 2 words (contains white space).

However slinky_spider does not (one word)

Quite often (and certainly in the testing phase) I will create a font set without a screen font (or at least not the correct one) - then you will know if the Web Font is being loaded correctly and not just using your System font instead.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Okay … this is the css file you’ve been provided:

@font-face {
    font-family: 'sinkin_sans300_light';
    src: url('SinkinSans-300Light-webfont.eot');
    src: url('SinkinSans-300Light-webfont.eot?#iefix') format('embedded-opentype'),
         url('SinkinSans-300Light-webfont.woff') format('woff'),
         url('SinkinSans-300Light-webfont.ttf') format('truetype'),
         url('SinkinSans-300Light-webfont.svg#sinkin_sans300_light') format('svg');
    font-weight: normal;
    font-style: normal;
}

The name given for font-family is what you need … including the quotes: ‘sinkin_sans300_light’. Don’t change ANYTHING ANYWHERE regarding the font names.

So, again for Edit Font Sets within Freeway :

  • Font Set Name : ‘sinkin_sans300_light’
  • Screen Font : select the corresponding font loaded on your machine
  • Alternative Fonts : ‘sinkin_sans300_light’

That’s it.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi David and Richard,
Yes, this makes sense. Richards example is how I have it here too. Strangely enough Softpress thinks that’s not how it should be done. I got an answer in the mail saying my alternative name should equal the screenname. I asked why, but that is still unanswered…

But there is a difference in your explainations about the apostrophes around the font name. I can understand really well why it should be like in Davids answer. So Richard, you use the apostrophes. What is best practice here?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I think I’ve lost you … best practice is exactly what I showed in my last post :slight_smile:

Or just take a look at Paul’s manual here: http://www.actionsworld.com/Actions/Caxton/

Richard

PS - Feel free to contact me off list if you want to …


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yes Richard, I completely understand you. I just do not understand why Softpress gives me the opposite advice!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options