[Pro] Dewplayer help

Hello guys,

Does anyone know how to integrate this player into freeway 5.4 pro: Dewplayer

I would like to have the vinyl version or the playlist version. I have tried with mark up and html mark up without luck. If anyone knows how, I’ll appreciate a step by step instructions or directions, thank you.

regards


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

How far have you got and do you have a link you can share with us

It should be as simple as using Insert>Markup Item and pasting the code into it (then position on the page where you want the player to appear)

<object type="application/x-shockwave-flash" data="yourplayerchoice.swf" width="200" height="20" id="yourplayerchoice" name="yourplayerchoice">
<param name="movie" value="yourplayerchoice.swf" />
<param name="flashvars" value="/mp3s/test.mp3|/mp3s/test2.mp3" />
<param name="wmode" value="transparent" />
</object>

Then upload the swf to the place on the server that you defined in the code above ie alongside the HTML page and the mp3 files into a folder called mp3s also alongside the HTML page.

Word of caution - not suitable if you want iOS devices to listen too.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi David,

At this point this microsite is a test, but I do want to integrate this player whether it be the vinyl or playlist. Here is what i have so far:

http://rgcreative.com/50years/

I’ll give a try your suggestion and see if it works.

thanks.

Carlos


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You are missing the playlist.xml file which should be alongside the HTML page at

http://rgcreative.com/50years/playlist.xml

Your inserted code contains this line

<param name="flashvars" value="showtime=true&amp;autoreplay=true&amp;xml=playlist.xml">

Which shows the path to the playlist.xml file

But the code in my previous posting - which I copied from the code configurator on their site - uses the mp3 filenames rather than an xml file

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi David,

I did what you suggested, copy paste your code (mark up) from above, replaced track/songs names on “playlist.xml” and uploaded along side the HTML page. Uploaded as well the “swfobject.js”. The result is, I can see the player but it is detecting the old code settings. If you click on play button the title displayed is “LA MOLDAU” which is not the mp3 song I replaced in the “playlist.xml”, and music is not played.

Is there something I’m missing? Is it mark up insertion the only thing I should do in freeway? Do I have to go to Page-Insert HTML mark up and what would this code be?

Could you please take a look and see what is wrong? Just click the same link above, I have replaced the files.

thank you again for your help and patience.

regards,

Carlos


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I am seeing the Title as Por Un Amor which plays for me.

One of your problems is that you have spaces in your mp3 file names.

Dont use spaces. Instead use underscores _ or hyphens -.

There are other issues but I have to go out so wont get a chance to look at this until later.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It may be that the player you have chosen - the playlist version requires an xml file to store the file names where some of the others you can use different mp3 files separated by the | pipe character.

How many mp3s do you wan to use? and what are their file names.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi David,

I only need 4. The names (currently) are:
01 Por Un Amor.mp3
04 La Cigarra.mp3
05 Tú Solo Tú.mp3
11 La Barca De Guaymas.mp3

I regards of the playlist.xml file, I have modified the code to match these 4 names and uploaded it at the same level of the HTML page.

here is what I have - playlist.xml:

<?xml version="1.0" encoding="UTF-8"?>
<title>Ounage Playlist</title>

<creator>Dew</creator>

<link>http://www.blup.fr/</link>

<info>The Best Playlist for Testing</info>

<image>covers/tracklist.jpg</image>



<trackList>



     <track>

      <location>mp3/01 Por Un Amor.mp3</location>

      <creator>Linda Rondstadt</creator>

      <album>Canciones de Mi Padre</album>

      <title>Por Un Amor</title>

      <info></info>

           
    </track>

    
    <track>

      <location>mp3/04 La Cigarra.mp3</location>

      <creator>Linda Rondstadt</creator>

      <album>Canciones de Mi Padre</album>

      <title>La Cigarra</title>

      <info></info>

     

    </track>

etc…

<----On freeway MARK UP (your code):----->

hope this makes it more clear. Anyhow I will keep trying and see what the problem is, thanks.

Carlos


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi David,

I got it to work, thanks again for your help.

cheers,

Carlos


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You still had spaces in your file names in that last example.

Glad you are working now.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options