[Pro] Email

Though I’ve updated to FWPro 5.6.5, I still find that clicking on a link in Mac Mail email (sent to myself via Safari ‘Mail Contents of This Page’) opens in the browser, rather than goes to the anchor in the email body.

I thought this was fixed in the new FW version, or was that a different issue?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I am guessing that Mail Contents of this Page is the culprit here, not Freeway. Freeway writes fully relative links – if you link to an anchor on the same page, the href of the link is written as #foo, not http://example.com/page.html#foo. The behavior you’re describing is precisely what you would get if Freeway had coded the latter style link.

Try to view the raw source of the e-mail and see if you can find the link to your anchor.

Walter

On Sep 18, 2012, at 8:55 AM, Sly wrote:

Though I’ve updated to FWPro 5.6.5, I still find that clicking on a link in Mac Mail email (sent to myself via Safari ‘Mail Contents of This Page’) opens in the browser, rather than goes to the anchor in the email body.

I thought this was fixed in the new FW version, or was that a different issue?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi Walt, thanks.

Well, here are my findings:

  1. Freeway puts in the full url to the anchor i.e. Easy Website Builder | Web Hosting Included | Ownwebsite.com

  2. If I manually remove the http://www.mywebsite.com/ part and send via safari, then read the raw source of the resulting email, I see that the link is still relative and does not contain the full path. Good.

  3. Yet still Mail opens the anchor in the browser.

So perhaps it’s Mail.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

The only reason it would ever do this is if the link is to a different page. You can test this pretty simply in Freeway. Make a new document with two pages. Create anchors on both pages. On each page, create a link to the anchor on the same page and on the other page. View the published source in a text editor. On the link to the same page, you should only see <a href="#foo">Link text</a> and on the link to the other page, you should only see <a href="page2.html#foo">Link text</a>. Under no circumstances will Freeway ever add a full http:// URL – ever. There are Actions that can add this for you, like Remote Resources, but Freeway (by itself) always writes relative URLs for portability sake.

Walter

On Sep 18, 2012, at 10:52 AM, Sly wrote:

  1. Freeway puts in the full url to the anchor i.e. Easy Website Builder | Web Hosting Included | Ownwebsite.com

freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It’s the ‘Create Email’ that adds the absolute link to the anchors.

But even if I remove them manually, the relative anchors still open in a browser somehow.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options