[Pro] Error Message - Could not save

Hello - I’m just adding pages to a site and when trying to save I’m getting this: "Could not save [site].html.freeway because of a program error. (-1309:114:9958)
Would anyone have a solution.
Many thanks.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Bill,

What version of Freeway are you using, and how large is your current document (file size)?

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Jeremy,
I am using version 7.0.3
The size is 6.49 GB.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I am using version 7.0.3

7.0.3 is pretty old.

You can update to the latest version (7.1.4) for free by going to our web page and clicking on "Download Freeway 7 here” after “Already own it?”

The size is 6.49 GB.

That’s a huge size!

Freeway runs into problems if a document is larger than 2 GB. What size is your most recent backup version?

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Sorry, I am mistaken. The size of both the document and the backup version are each 2.13 GB. I wasn’t even aware until today that Freeway was back in business, so I haven’t downloaded the latest version. I will do so.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

2.13 makes more sense.

2.14 GB is the maximum size of a Freeway file, so you’re exceeding this limit when you add new pages.

One way that you should be able to reduce your document size is by going to the Edit Resources dialog and clicking on Resample All.

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I’m now able to save it. I upgraded to the latest version and did the Resample All. The file size still says 2.15 GB but it’s working. I’m not really clear about why that’s such a large size. I have no videos on the site, though I do have quite a few images. I assumed sites with many videos and more images would be much larger than mine.

Many thanks for your help!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

2.14 GB is the maximum file size that can be saved using 32-bit file APIs, because that’s the largest size that is representable as a 32-bit (signed) integer.

Freeway saves preview copies of images within its document format, and uses these when displaying images on screen. Unless you lose the original image, it will use the original image rather than the preview image when publishing.

If you resize an image to be smaller after you imported it, Resample All will shrink the size of the preview image - which should help to reduce the document size.

One other thing you could do is look in the Document tab of the Document Setup dialog and check that “Document graphics” is set to “Thousands” (rather than “Millions”) of colours. If it’s set to “Millions”, change it to “Thousands” and then Resample All again.

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Could it also be that images are being used as pass-through, therefore not resampled or downsized by FW?

On 6 Nov 2018, at 12:21, Jeremy Hughes email@hidden wrote:

2.14 GB is the maximum file size that can be saved using 32-bit file APIs, because that’s the largest size that is representable as a 32-bit (signed) integer.

Freeway saves preview copies of images within its document format, and uses these when displaying images on screen. Unless you lose the original image, it will use the original image rather than the preview image when publishing.

If you resize an image to be smaller after you imported it, Resample All will shrink the size of the preview image - which should help to reduce the document size.

One other thing you could do is look in the Document tab of the Document Setup dialog and check that “Document graphics” is set to “Thousands” (rather than “Millions”) of colours. If it’s set to “Millions”, change it to “Thousands” and then Resample All again.

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Could it also be that images are being used as pass-through, therefore not resampled or downsized by FW?

Good idea, but although pass-through images are not resampled on output, they still have preview copies that can be resampled within the document.

Jeremy


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options