[Pro] Exhibeo Import JavaScript Error

Been using Exhibeo for a few months now in my Freeway site I just rebuilt. Have a couple dozen galleries made and uploaded without issue. Today I received this one …

JavaScript Error - Action: Exhiebo Import … fwParameters[“re” +i] has no properties

I did nothing different in creating this one, it exported to Freeway just fine, just that I get that error now when selecting the output file in the Freeway action.

The only thing different about this gallery from the previous ones is that the previous ones were 100-200 images, this one is 999 (a wedding).

What is wrong and how do I fix it?
Thanks
Sean


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Exhiebo 1.1.4

Freeway Pro 7.1.3

Mac OS X 10.7.5


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I tried it with other Exhibeo Themes with the same error.

I tried it with another set of images, 500 of them, and it still comes up with the same error.

I tried it with just 1 image and it loads just fine without the error.

Anyone have any idea on how I can resolve this?


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

(Softpress)
JUN 13, 2016 | 05:40PM BST
Hi Sean,

There isn’t a limit in Exhibeo itself, however there is a limit to how many you can import into Freeway through the Action. I think that the max was somewhere around 485-500, so you should be able to get it to work if you split the 1000 Image gallery into 3. You should then be able to import the 3 working galleries individually into Freeway. The reason the limit is there in the first place is because it may start to cause problems with page/ gallery loading time, so do keep in mind that by having all these images in your site you could end up with these problems as well

Let me know if you need anything else.

Kind regards

Softpress Support


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I seem to be having the same problem. Same version around 30 images
Getting this message.
"An error was detected in the JavaScript of the Action “Exhibeo Import” Any suggestions? Do I need to upgrade?
This is in a responsive site that I am building.
John


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

30 is all you are getting? Even tho they claimed about 500 is the limit, I found that I am getting about 250 for the maximum.

It may be more about total file size than it is about just the total number of images. You may have to play with the dimension/resolution of the images you are dropping into Exhibeo to process. I plan on doing that with my next photo session. Currently I had been exporting my images for web upload at 72 res and 1600 pixel long edge. About 230 pictures in the Thumblie theme results in a Exhibeo Export file around 65MB and it imported that no problem. I tried a gallery of 267 images and it gave me the error.

The limit is not coming from Exhibeo but rather from the Freeway Action I think wanting to error on the larger import files.

This is my follow up response from Softpress Support … “Thanks for getting back to us with your findings. I can see that we need to run some tests to see what the limit is (if there is a particular fixed limit, which I was originally told was a particular number of images) or whether it depends on the file sizes of the imported images. It is very unusual for customers to request the need to build such large galleries (though I can certainly understand the requirement in your case). It is, however, worth bearing in mind that there may be some loading time issues (as the code required to handle hundreds of images loads before the functionality starts to work) – so splitting a huge single gallery into multiple galleries of a more manageable size is usually advisable.”

So that is what I did, being a wedding photographer and wanting to get 1000 images into a gallery, I had to break that down into 5 separate galleries and put each of those into the same webpage for the client. Still a large file site page but it works … so far.


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Sean
I can’t even get it to publish so switched to the Amazing Slider program.
Not sure if it has a limit but solves my problem. Never been happy with Exhibeo.
John


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I am new to Exhibeo and still trying to figure it out in how it will work best for me. Really all this website stuff is over my head, so doing this myself as a noob I look for the path of least resistance.


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I was having this problem and remember in the past that when you select the place to put your Action Item you need to backspace. This worked for me.


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thanks nik. Can you explain that a little better so that someone like me (website retarded) can understand and hopefully replicate?


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I am not a Freeway master in any way but if you draw an html item to be the action container. When you put the cursor inside the container to insert the action item, press backspace before you insert the action. Hope this makes sense!


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I am having the same issue with a gallery of only 255 images. Very frustrating when your workflow is so impeded.

Any other workarounds to get it to work with the 255 images?

Its never been a problem before.


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I have now managed to get 245 images to work. 10 short of the total. This seems a bit random and it would be good to know why this is an issue at all?

I am using version 1.0.6 of the Exhibeo action. Version 1.1.4 of Exhibeo itself.

Is this just a recent issue?


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

From what I was told by the folks at Softpress the issue is not with Exhibeo and what that program does, the issue is with the Exhibeo Import Action within Freeway. It is the Action that is limiting the number of images.

It may not exactly be the just a number either but maybe the total file size of the .xbExport file. I have not taken the time to play around with it yet to see if I made my photo sizes smaller before running thru Exhibeo if that would allow me to place more images in one gallery or not …?

Exhibeo 2 has it’s own new Exhibeo Import 2 Action … I wonder if that new Action is still choking down on the number/size we can do?

I too am finding that it is around the 250 images mark that I am taking a gamble as to if it will work or not.


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

The Exhibeo 2 action has the same limitation. I just tried it with 391 images and got the error. Broke it up into 2 sets of about 200 each and that went with no problem.

Thats not ideal, but I made a template page in Freeway to duplicate that has the multiple gallery sets on it. The best I could come up with for providing the client all their images on one page.


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I have been frustrated by this issue yet again after managing to get a gallery working with the limitation of 245 images.

I had tried reducing the image size and increasing the number of images but still the same error occurred.

Once I had it working again when reverting back to 245 images it was ok. Then when trying to upload another gallery on the same site which had a smaller gallery the 245 image one started giving the error message again thus inhibiting the upload of the smaller gallery as well.

Really not very helpful at all.


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I just did a session with 250 images that it balked at. Cut it down to 230 and it went thru. So somewhere in between lies the number.

The overall issue is not what that cutoff number is but more so why it is there and how to get them to unrestrict it. On wedding days I want to push anywhere from 800-1200 images online … it would be nice to do them all in one gallery on one page.

I used to do it with jAlbum but I do like the “integration” of Exhibeo with Freeway and the Thumblie theme.


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hello,

I have experimented before and try to limit each gallery to 200 or less images in Thumlie.

I have a example for you below that uses two pages.

It is better to break them up anyway because it would take to long to download even the thumbnails.

You might have a fast connection but some people don’t. If it does not load right away they move on.

http://www.templecityphotos.com/Gallery%202016/06_08_16_emperor.html

Sincerely,

Jerry Jambazian

wwwTempleCityPhotos.com

From: Exhibeo email@hidden on behalf of Sean email@hidden
Reply-To: email@hidden
Date: Tuesday, July 5, 2016 at 5:12 PM
To: email@hidden
Subject: Re: [Pro] Exhibeo Import JavaScript Error

I just did a session with 250 images that it balked at. Cut it down to 230 and it went thru. So somewhere in between lies the number.

The overall issue is not what that cutoff number is but more so why it is there and how to get them to unrestrict it. On wedding days I want to push anywhere from 800-1200 images online … it would be nice to do them all in one gallery on one page.

I used to do it with jAlbum but I do like the “integration” of Exhibeo with Freeway and the Thumblie theme.


Exhibeo mailing list

email@hidden

Update your subscriptions at:

https://freewaytalk.softpress.com/person/options


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

On 6 Jul 2016, 12:12 am, Sean wrote:

The overall issue is not what that cutoff number is but more so why it is there and how to get them to unrestrict it. On wedding days I want to push anywhere from 800-1200 images online … it would be nice to do them all in one gallery on one page.

I know what you mean Sean about getting them all up at once.
I have however found that for presentation purposes and to make it easier for clients to view so many images then I have split the event images up into the different parts and created a small website with a menu to view the different sections. Its a better solution all round I felt.
A wee bit more work but worth it I feel for the clients benefit.


Exhibeo mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options