[Pro] Freeway upload

This is a general Freeway question. I have recurrent problems uploading. The connection is made, and then there is an alert ‘Comparing files’ which often sits there forever, or other times starts uploading, and then stops and sits there forever. It is obviously a recognized problem because there is advice to try passive/non-passive modes, but often this doesn’t help. Restarting the computer sometimes helps. What is the cause of this, and is there a solution? Thanks!

http://paulscottinfo.ipage.com/england/cathedrals/coventry/


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

If restarting your Mac helps, you may want to look at replacing your clock battery in your Mac. One of the things that happen during an upload is that the files on your server are compared for creation date with the files on your Mac (in your Site Folder). All computer clocks drift over time, so the Mac corrects the time occasionally (and at start-up) by synching with the NTP (Network Time Protocol) servers on the Internet. Servers do this as well. As long as a file is within a margin of error of being saved at the same time on both the server and your Mac, it won’t be sent up to the server. But if the time difference appears to be too great, it will be marked as needing to be sent up to the server. You may not have changed every file in your site, but if your clock is off, it will appear that way to Freeway. Given a large enough site, this could take a very long time to compute.

That’s all a theory, but it may explain what is happening, and why it appears to be variable over tries.

Walter

On Sep 12, 2017, at 2:47 AM, Paul Scott email@hidden wrote:

This is a general Freeway question. I have recurrent problems uploading. The connection is made, and then there is an alert ‘Comparing files’ which often sits there forever, or other times starts uploading, and then stops and sits there forever. It is obviously a recognized problem because there is advice to try passive/non-passive modes, but often this doesn’t help. Restarting the computer sometimes helps. What is the cause of this, and is there a solution? Thanks!

index


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thank you Walter. I’ll look into that. Paul


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Walter, replacing the clock battery on my iMac looks like it might be beyond me, and in any case there seems to be nothing wrong with the clock function. However, something else I have tried which seems to help is to add a further unconnected file or folder to the Site Folder. I labelled this 000 with the thought that it might be discovered early on in any search, but in light of your remarks, perhaps it is the newness of the folder/file which makes the difference?
Paul


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

On 12 Sep 2017, at 15:36, Walter Lee Davis wrote:

If restarting your Mac helps, you may want to look at replacing your
clock battery in your Mac. One of the things that happen during an
upload is that the files on your server are compared for creation date
with the files on your Mac (in your Site Folder). All computer clocks
drift over time, so the Mac corrects the time occasionally (and at
start-up) by synching with the NTP (Network Time Protocol) servers on
the Internet. Servers do this as well. As long as a file is within a
margin of error of being saved at the same time on both the server and
your Mac, it won’t be sent up to the server. But if the time
difference appears to be too great, it will be marked as needing to be
sent up to the server. You may not have changed every file in your
site, but if your clock is off, it will appear that way to Freeway.
Given a large enough site, this could take a very long time to
compute.

That’s all a theory, but it may explain what is happening, and why it
appears to be variable over tries.

Walter

On Sep 12, 2017, at 2:47 AM, Paul Scott email@hidden wrote:

This is a general Freeway question. I have recurrent problems
uploading. The connection is made, and then there is an alert
‘Comparing files’ which often sits there forever, or other times
starts uploading, and then stops and sits there forever. It is
obviously a recognized problem because there is advice to try
passive/non-passive modes, but often this doesn’t help. Restarting
the computer sometimes helps. What is the cause of this, and is
there a solution? Thanks!

index


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

NTP should continue to run as a daemon after startup, keeping the clock
in sync with the rest of the world.

If yours doesn’t, you can run the command
sudo ntpdate -B time.euro.apple.com
(or wherever you preferred time server is) in Terminal (it will ask for
your password). If this fails with
ntpdate[84938]: the NTP socket is in use, exiting
then the ftp daemon is running.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thank you Walter and David for your input. I haven’t followed your advice David as the time on my computer seems to be exactly right. My problem is still continuing. It never seems to occur on a first upload, which suggests that it is the ‘comparing files’ that causes the problem. This morning I tried adding a new unconnected file in my existing Freeway program and publishing it. The file appears in the Site folder with today’s date and time – about two days later than any of the other files! However the Upload still gets stuck on the ‘Comparing files’. I’ll just have to make sure each site is completely correct when I first upload it. Ha!!

Paul


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Paul – I’m not an expert user, but I found a workaround based on a similar issue that I saw on the knowledgebase. I was having an issue where it was taking a ridiculous amount of time to upload my site using FW’s built-in FTP. Part of the issue was that FW was electing to re-load my html 5 audio elements (a number of mp3s) when no change had been made to those files. The average upload speed was about 10% of my maximum throughput with my cable ISP. I decided to try using Fetch’s mirror function to sync the site folder to my server after publishing in FW. The uploads are now at 100% of my expected throughput speed and it only loads the files that have actually changed. Works perfectly. HTH!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options