[Pro] Google Map Marker

A simple page with a Google Map using the action in FW6

http://www.deltadesign.co/PTL/mapwithout.html

and the map appears.

Try to add a marker using either the built in settings or the Google Maps Marker action

http://www.deltadesign.co/PTL/mapwith.html

And I get these errors:

SyntaxError: Unexpected EOF
mapwith.html:1ReferenceError: Can’t find variable: fwGMapInit

Has Google changed something?

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Hi David,

It might have something to do with the code being set to “More Efficient”. Try changing it to “More Readable” to see if that helps.

Joe

On 28 Feb 2013, at 00:16, DeltaDave email@hidden wrote:

A simple page with a Google Map using the action in FW6

http://www.deltadesign.co/PTL/mapwithout.html

and the map appears.

Try to add a marker using either the built in settings or the Google Maps Marker action

http://www.deltadesign.co/PTL/mapwith.html

And I get these errors:

SyntaxError: Unexpected EOF
mapwith.html:1ReferenceError: Can’t find variable: fwGMapInit

Has Google changed something?

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

It might have something to do with the code being set to “More Efficient”.

You have confused me there Joe as in File>Document Setup and on each individual page the code is set at More Readable!

I will flip and report back.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

OK

My code (according to the FW app) was set as More Readable for every page.

So first I set all pages to More Efficient, published and then reverted to More Readable and republished. Still no Marker.

So contrary to Joe’s advice I set it to More Efficient and republished and that did it. I have a Marker!

Is it a Bug or just a peculiarity that Google Map Marker users should be made aware of?

D :slight_smile:


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Ah, if that was the case then setting the line endings to Unix (in doc setup) will have been the culprit (the effect looks the same in current WebKit browsers).

Joe

On 28 Feb 2013, at 22:43, “DeltaDave” email@hidden wrote:

OK

My code (according to the FW app) was set as More Readable for every page.

So first I set all pages to More Efficient, published and then reverted to More Readable and republished. Still no Marker.

So contrary to Joe’s advice I set it to More Efficient and republished and that did it. I have a Marker!

Is it a Bug or just a peculiarity that Google Map Marker users should be made aware of?

D :slight_smile:


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

then setting the line endings to Unix (in doc setup) will have been the culprit

Yup - that was it, mine were set to Macintosh.

Thats what you get for not setting the defaults (with no Doc open) when working with FW6.

Simple - but annoying.

Thanks Joe for that reminder.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options