[Pro] HTML and not preview

I uploaded 5.4 and have noticed a problem. I started a new website this morning and when I clicked to see the preview all I could see was code. There were also other issues with rollover buttons not reproducing correctly. Even when viewed in the browser. I dumped 3 versions before it corrected itself. Having uploaded the site it all seems okay. I them went back to the Freeway site made a ‘save as’ and the preview problem has reappeared on both the saved as version and the original, on the home page but not the other only live page. Any ideas guys? I am trying to impress a potential client and this isn’t quite helping!


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Have you changed the file ending by any chance… in other words do these pages you are having problems with end in .html or other?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thank you for responding.

I usually end ‘index’ as the home page with html. In this instance I did that and it led not to the page I uploaded but to a php page. I tried all sorts of things and then decided to put php instead of html and the site is in position. So yes why? All my 35 websites but one (now two adding this one) are hosted with my hosting partner. By all means please go view the page http://www.go4marketing.net


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Then that is why you are seeing code when you preview in Freeway, if
you switch to .html you will see a preview. You can see all is well
when the pages are uploaded because your hosting account has PHP.

HTH

On Jul 28, 2009, at 9:06 PM, Alan Reading wrote:

Thank you for responding.

I usually end ‘index’ as the home page with html. In this instance I
did that and it led not to the page I uploaded but to a php page. I
tried all sorts of things and then decided to put php instead of
html and the site is in position. So yes why? All my 35 websites but
one (now two adding this one) are hosted with my hosting partner. By
all means please go view the page http://www.go4marketing.net


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sorry, to answer this bit.

Your hosting company probably use index.php as their default index
page and for any index.php page to load before a index.html page,
removing the index.php page with Fetch or other would have sorted that
problem although you may also find now if you change it from .php
to .html then Freeway will replace the index.php file with the
new .html file as it was placed there with Freeway. When you changed
the Freeway index.html page to .php it will have overwritten the
index.php file the hosting company had there.

HTH

On Jul 28, 2009, at 9:06 PM, Alan Reading wrote:

I usually end ‘index’ as the home page with html. In this instance I
did that and it led not to the page I uploaded but to a php page. I
tried all sorts of things and then decided to put php instead of
html and the site is in position.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

So, if I want to see a preview in Freeway end index with html but when I upload it to the other persons hosting company replace html with php.

Thank you Mike, I appreciate it.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

That’s one way to look at it. Another is to get in front of the
problem with this hosting provider, because unless you are actually
using PHP, there is no reason to save your files as PHP.

Simply deleting the index.php from your site root folder (using Fetch
or Transmit) will do the job.

Walter

On Jul 28, 2009, at 3:34 PM, Alan Reading wrote:

So, if I want to see a preview in Freeway end index with html but
when I upload it to the other persons hosting company replace html
with php.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Well no, I used this for your example, many hosting companies use
index.html before looking for index.php

The first thing I would do would be to have a look insode the home
directory and make sure you know what is there and why it is there
before messing with the existing files, when you understand what pages
and/or files are there you can then proceed.

Most hosts use index.html as the first default page to be read in a
directory, some… like your hosting company for some reason use
index.php as the default page to be read, I don’t know why! any php
hosting account servers I have come across look for a index.html
before they look for index.php page.

HTH

On Jul 28, 2009, at 9:34 PM, Alan Reading wrote:

So, if I want to see a preview in Freeway end index with html but
when I upload it to the other persons hosting company replace html
with php.

Thank you Mike, I appreciate it.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

This particular problem only revolves around the one new client, not my regular hosting partner. Usually I use index,html

I’ll get the site up then ask his hosting company about it.

Thanks again.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options