[Pro] Https and Background Supersizer

In my quest to get everything running smooth on my sites after changing to https it seems that the Background Supersizer action doesn’t want to collaborate. I get this message: “Parts of this page are not secure (such as images).”

Pages without the action get the go ahead. Walter’s HTTPS CDN Helper has been applied.

Can anybody have a look?

Jon

https://sail-chartering.com/index.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

It seems to work here. Was there another page that didn’t work correctly?

Walter

On Jul 19, 2018, at 6:05 AM, Jon H email@hidden wrote:

In my quest to get everything running smooth on my sites after changing to https it seems that the Background Supersizer action doesn’t want to collaborate. I get this message: “Parts of this page are not secure (such as images).”

Pages without the action get the go ahead. Walter’s HTTPS CDN Helper has been applied.

Can anybody have a look?

Jon

https://sail-chartering.com/index.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I’m sorry, I accidentally left out some information. The above mentioned site has only the index page using supersizer and gets a warning, while the other pages work fine, no warnings.

However, the site has a sister site, https://fariikind.com, where all the pages use supersizer, except for one (Gastronomy), and consequently get a warning.

Warning: padlock with yellow triangle(Firefox) stating the page is not completely secure.

Furthermore, on the gallery page on both sites the Smooth Scroll action has stopped working.

Jon

PS. The reason for using the supersizer with just one bakground picture is that I found it was the only way to not have the image scroll on ios devices .


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

On the Gastronomy page I do believe that you misspelled chili.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

A little off topic, Robert? But thank you for commenting.

UK and India: Chilli
USA: Mostly Chili, but some also use chilli.
Chile is also used in many Spanish speaking countries.

I decided on chilli as the site is with UK English.

I’ll stay with chilli. Unless you have strong objections. But nice to have observant participants on this forum, also on grammar and such. And don’t hesitate to write if you find more.

Jon


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Both pages throw this error for me:
The page at https://fariikind.com/ was allowed to display insecure content from http://fariikind.com/404.html.

Look how your 404 page is handled, and make sure that it is also served up using https. Fixing that will clear the error.

Also, obviously, find out why there is a 404 error being thrown. It looks as if an image called progress.gif is missing from a folder named images - find out where that’s gone and you should be OK.

I am also seeing this error on other pages:
TypeError: undefined is not an object (evaluating ‘r.options.slides[vars.current_slide][e]’)
I don‘t know the cause, but is there an Action or other JavaScript being employed that may cause this? It’s on most pages (not Gastronomy or The Crew pages).


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thank you, Paul, for visiting.

On https://fariikind.com I have now removed the Supersize Action on all pages, and no errors are to be found. The backside is that on ios devices the background image is scrolling with the rest of the content. Which is not what I wanted. And on the front page I had to give up the slideshow. Does anybody have a remedy or two?

And the Smooth scroll Action is not behaving. This happened after switching to https.

Jon


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Sorry, folks, with two more or less similar sites I get confused from time to time. I did the changes on

https://sail-chartering.com/index.html

So there.

Jon


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Ok, I’ll try again, with a question that might be of interest to others:

Does anybody have a suggestion how to replace the Supersize Action with something that does the same thing, meaning keeping a background image or slideshow fixed in the window while all other content is floating on top? Also on ios devices?

Jon


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options