[Pro] JAVA Script with showcase galleries

Hi All,

got a major problem with an old website I originally built for a client in Freeway 5.5 using showcase galleries for the picture content on each page. I now have to make some changes to one of the galleries, replacing some pictures, which I have done in Showcase, saved it and exported it to Freeway. But when I open up the site in Freeway to import the new gallery I get a JavaScript Error for all the showcase galleries in the site. All the gallery/slideshows have disappeared and I cannot re-link them.
This is a major problem as the site has over 50 of these and I really don’t want to re-build the lot!
I am running El Capitain on my Mac and have had JavaScript problems with Adobe CS but the Java plugin I downloaded for that cured it.
Is there one for Freeway?
I have tried opening the Freeway file in Freeway Pro, I only have version 6, but the same problem occurs.
Do I need a newer version of Pro or of Showcase or am I doomed to rebuild the whole site? - I do hope not, I don’t build many sites so haven’t used the software for a while, I need advice please, thanks in advance…
Cheers, Neil


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Well, I can help you with part of this. Java and JavaScript share four letters – and absolutely nothing else. So that’s not the issue here.

Troubleshooting steps:

  1. Make a duplicate of your Freeway document in the Finder, and in Freeway, first make sure no other documents are open, and open only the duplicate document. Before you do anything else, open the Edit/Document Setup dialog, and set the Site Folder to a new, empty folder well apart from the original site folder. Open Edit / Assets, and press Resample All.

  2. Try to publish, and see what happens. Pay close attention to the filenames that zoom through the Publish dialog, because the last one you see is the last page that worked. If all goes well, then you’re set.

  3. If you get an error, post the actual error text here (sorry, it’s not copy-pasteable, but you can take a screenshot and post that somewhere public like Dropbox, and then a link to THAT).

Report back how it goes, and someone (perhaps the author of the afflicted Action) will be able to help you out. The more precise your report is, the better.

Walter

On Mar 2, 2017, at 10:37 AM, NeilMM email@hidden wrote:

Hi All,

got a major problem with an old website I originally built for a client in Freeway 5.5 using showcase galleries for the picture content on each page. I now have to make some changes to one of the galleries, replacing some pictures, which I have done in Showcase, saved it and exported it to Freeway. But when I open up the site in Freeway to import the new gallery I get a JavaScript Error for all the showcase galleries in the site. All the gallery/slideshows have disappeared and I cannot re-link them.
This is a major problem as the site has over 50 of these and I really don’t want to re-build the lot!
I am running El Capitain on my Mac and have had JavaScript problems with Adobe CS but the Java plugin I downloaded for that cured it.
Is there one for Freeway?
I have tried opening the Freeway file in Freeway Pro, I only have version 6, but the same problem occurs.
Do I need a newer version of Pro or of Showcase or am I doomed to rebuild the whole site? - I do hope not, I don’t build many sites so haven’t used the software for a while, I need advice please, thanks in advance…
Cheers, Neil


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hi Walter,
thanks very much for your reply.
I managed to delete the new gallery and showcase file I had tried to import and replaced them with the old showcase files from a backup I had made previously. Once I had republished, all the galleries reappeared. I found the files causing the problem were some of the image files my client had sent me to put in the new gallery, she had renamed them using using / in the name and changed the .jpg to .jpeg. Once I had taken these out and changed all of them to .jpg and remade the showcase gallery it has now imported OK. The only warning notes I got was that some html files associated with the site would be overwritten.
It all seems to look OK now, will upload it tomorrow and hopefully it should work.
Thanks for your help, much appreciated, Neil


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options