[Pro] Line breaks using List function

At FW tech support’s suggestion, I am using the List function instead of the Inspector’s Indent function.

In the example link, please look at the line spacing between the single-indented List sentences (••) and the double-indented ones (•).

Looking at it online in Safari and in our PC’s Internet Explorer, there is a DOUBLE space between the sentences, which is what I WANT. But in Firefox for Mac, there is only a SINGLE space between a one-indented (••) and a two-indented (•) sentence, which I don’t want.

Any idea why the line spacing is correct on Safari and PC Internet Explorer, but incorrect on Firefox for Mac?

(By the way, the •• and the • are added by me. They are not the bullets that Freeway tries to add, which I remove by clicking Unbulleted.)

http://www.jimfeeney.org/powerofhealingprayers.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

All browsers have their own idea how a “vanilla” HTML page should look. If you were to suppress the CSS stylesheets in your page, the page would still have some styling to it – it wouldn’t look just like run-together text, all the same size. These built-in styles exist as a sort of backstop to any other styling you may add to your page. If you override them (which is easy, because they don’t have a lot of specificity to them) then your style will override any property you set. But if you don’t set the exact property that you are seeing (margin-top and margin-bottom, in this case, I am guessing) then whatever the browser has defined as default will shine through. Imagine you are painting a picket fence. You paint the pickets white, but the green grass of the lawn beyond still shows through the slots. The grass is the browser’s default. If the browser decides, ultimately, that grass should be purple instead of green, no amount of adding white paint to the pickets will make it any other color.

The other thing to realize here is that when you use a real list (rather than styling text to appear to be a list) you are creating a different set of tags, each of which has its own notion of how it should lay out on screen.

The best way to figure out where this style is coming from is to use your browser’s developer console to inspect the rendered page. Preview in a browser, and then Control-click on the element in question and look for something that looks like “Inspect element” in the contextual menu. This should open an inspector showing you the styles that apply, and where they come from. If you don’t see this option in Safari, then look in the Advanced preferences tab for the “Enable develop menu” option, and tick it on.

Walter

On Mar 3, 2014, at 3:58 AM, Jim Feeney wrote:

At FW tech support’s suggestion, I am using the List function instead of the Inspector’s Indent function.

In the example link, please look at the line spacing between the single-indented List sentences (••) and the double-indented ones (•).

Looking at it online in Safari and in our PC’s Internet Explorer, there is a DOUBLE space between the sentences, which is what I WANT. But in Firefox for Mac, there is only a SINGLE space between a one-indented (••) and a two-indented (•) sentence, which I don’t want.

Any idea why the line spacing is correct on Safari and PC Internet Explorer, but incorrect on Firefox for Mac?

(By the way, the •• and the • are added by me. They are not the bullets that Freeway tries to add, which I remove by clicking Unbulleted.)

http://www.jimfeeney.org/powerofhealingprayers.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks, Walter. That clears it up. By the way, I appreciate the time you take to give detailed answers to those of us in need of help.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options