[Pro] MooTools accordian not closing

I have set up an accordian using moo tools but have a problem. If I have 4 or 5 accordian sections. All work perfectly except the last one. The last section loads open (as well as the one which I do want open) and wont close at all. I have tried to isolate the problem and can’t. But I have identified that it doesn’t seem to matter how many sections there are as much as how low down a page they are. If there is a lot of content in the top accordian the bottom one remains open and inactive to mouse clicks. Have a look at the problem: http://amandafashions.co.uk/webwithmoo/
I have created a second page, the only difference is literally the content in the top section. http://amandafashions.co.uk/webwithmoo/lesscontent.html
Any ideas anyone…


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

OK, I can’t figure this out precisely, not knowing how this mootools action is supposed to be set up. But I’m looking at your Page source for both pages.

I’ve used the scripty Accordian Action and found that it required a precise order and heirarchy for H1s and P tags. I think I see something wrong in your code for the broken page that reminds me of my problems with Scripty Accordian, but I don’t know exactly what it means!

The last of the four “sections” (<div id=“events3”…) is missing some lines of code seen in all the other sections. One line of code in this section doesn’t have a “class=“mL_1"” at it’s end. One line of code says “<a href=”#” " where all the other sections say "<a class=“mooFaqHref mooFaqOnclick” "

No idea what all this means, but I’d try to rebuild the whole thing from scratch, making sure that each Section gets coded and treated the exact same way.

And maybe leave out the graphic headings during your test. Just to keep things simple.

I might be seeing a red herring. don’t really know.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Did you watch my video on this?

http://www.mediafire.com/?792mxebydss

Password: apple

I know I’ve built accordion’s at least 10-12 deep and never had a problem with it. Hopefully this will help solve the riddle.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Dan and Bucky. The difference in the code is only created once the copy in the first section changes. That is literally the only change between it working and not working, so something is happening to the code when the html files are being built, it has nothing at all to how the Freeway document was created.
I’ve just watched your screencast and that basically demonstrates everything that I did to create the accordian. I encountered my problem when I added the content. Everything I did could not get around the problem once the content grew. I created it from scratch a number of times, in the same document and in new ones - still the same issue.
But… I have now worked it out. I was puzzled because it seemed that it only occurred when the accordian reached a certain level down the page. On studying everything very carefully I realised that the list of items on the left that displayed each section of the accordian was different for the faulty section. There were very faint crosses in the squares next to each item in the list, and this applied to the sections that stopped working - so something was causing those checks to be created.
Earlier in my problem solving I had tried making the page deeper under the document set up menu [despite the fact that the content was never longer than the page] but it made no difference. I revisited it, but this time I made the document 3000px deep, and then additionally I clicked on the page setup in the Inspector and made the page 3000px deep and hey presto it worked.
It took a while but that seems to have solved it, I now have a long section in one, a form in another and a google map in another all working and designed as planned…


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Sometime around 5/9/09 (at 07:07 -0400) PixelAce said:

this time I made the document 3000px deep, and then additionally I
clicked on the page setup in the Inspector and made the page 3000px
deep and hey presto it worked.

The options found in File > Document Setup only affect pages that
you make subsequently, not pages already there. So changing that
won’t have made any difference… but changing the actual page height
in the Inspector palette would.
It could be that the items weren’t layered, which would mean that any
items not actually on the page wouldn’t be published.

k


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options