[Pro] No Link not working?

At the bottom right hand side of this webpage I have a © Copyright and a Designed by Credit. http://idealynx.com/clients/cs/index.html

I’ve told Freeway Pro that there is No Link for the credit, but it’s still trying create a link, albeit to this page. Why is this happening?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Where did you change it to No Link - on this page or on the Master.

Whichever you did you will need to ensure that Use Master Content/Settings is set appropriately.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Both


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

This is because the item has had the CSS Menus Action applied to it. Remove the Action from this item and style it as a simple run of text.
Regards,
Tim.

On 23 Jan 2012, at 00:34, RavenManiac wrote:

I’ve told Freeway Pro that there is No Link for the credit, but it’s still trying create a link, albeit to this page. Why is this happening?


FreewayActions.com - Freeware and commercial Actions for Freeway Express & Pro - http://www.freewayactions.com
FreewayStyle.com - Free Freeway templates and parts to download, use and explore - http://www.freewaystyle.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yes, but I want the CSS Menus Action applied to it because the design credit text is linked. Why isn’t the No Link instruction working on the copyright?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

When you say ‘No Link instruction’ do you mean you’ve just not set a link on the text?

The CSS Menus Action will make each menu item text a link regardless of if you’ve set a link on the item or not. It has to do this to get any child (or grandchild) menu items to appear. Without the link these child menus wouldn’t appear in certain browsers.
If you set a link on the text (as you’ve done on the credit text) then the Action will use that otherwise it will create an empty anchor (#) and link to that.

I can see what you are attempting to do and unfortunately the CSS Menus Action doesn’t currently support non linked text. It could certainly do this in the future but it would have to check to see if the item had any child items before it could safely remove the link.

My suggestion would be to remove the copyright text from the CSS Menus Action and add it as a regular run of styled text.
Regards,
Tim.

On 23 Jan 2012, at 14:52, RavenManiac wrote:

Why isn’t the No Link instruction working on the copyright?


FreewayActions.com - Freeware and commercial Actions for Freeway Express & Pro - http://www.freewayactions.com
FreewayStyle.com - Free Freeway templates and parts to download, use and explore - http://www.freewaystyle.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Tim, thanks for your help.

I was able to make the CSS Menu with No Link work on this website: http://idealynx.com/clients/geekforce/

So I can’t understand why it won’t work on the one we’re talking about.

Kelly


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

There is still a link there but it is quite well hidden! :slight_smile:

If you hover over the copyright text on that page you’ll see there is still a link applied to the text (#). It is less obvious as the hover text colour is the same as the regular text colour.

Also if the browser window is larger than the web page the page won’t jump back to the top if the link is clicked. It will just look like nothing has happened. Make the window smaller than the page and the click the copyright link. and the page will snap back to the top of the screen as it follows this empty anchor.
Regards,
Tim.

On 23 Jan 2012, at 15:16, RavenManiac wrote:

was able to make the CSS Menu with No Link work on this website: http://idealynx.com/clients/geekforce/

So I can’t understand why it won’t work on the one we’re talking about.


FreewayActions.com - Freeware and commercial Actions for Freeway Express & Pro - http://www.freewayactions.com
FreewayStyle.com - Free Freeway templates and parts to download, use and explore - http://www.freewaystyle.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Tim. I clearly need to rethink this. Do you think simply placing an HTML text box inside of the bottom footer and then linking the design credit will work?


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Yep, that worked perfectly. Thanks for your help Tim.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Excellent. I’m glad you got this working OK in the end.
Regards,
Tim.

On 23 Jan 2012, at 16:15, RavenManiac wrote:

Yep, that worked perfectly. Thanks for your help Tim.


FreewayActions.com - Freeware and commercial Actions for Freeway Express & Pro - http://www.freewayactions.com
FreewayStyle.com - Free Freeway templates and parts to download, use and explore - http://www.freewaystyle.com


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options