[Pro] Partial pages for templates

Is it possible to have Freeway create an html file that only contains part of a page, e.g. a

with its contents, without the whole etc?

I’m using Freeway to create some ExpressionEngine templates and being able to do that would help my team’s work flow.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

The TemplateHelper Action can make those for you, although it is something of an expert’s tool. If you’re already working in Expression Engine, then I imagine it could work well for you. Note that it always prefaces the filenames of its generated “partials” with an underscore. Also you will need to spend some time or thought (or post-design hand-coding) working out how to make links within those partials resolve correctly.

Walter

On Jun 9, 2016, at 8:59 AM, Dan Searle email@hidden wrote:

Is it possible to have Freeway create an html file that only contains part of a page, e.g. a

with its contents, without the whole etc?

I’m using Freeway to create some ExpressionEngine templates and being able to do that would help my team’s work flow.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I did partials for a WordPress template and luckily enough screencasted this some moons ago. It’s just a raw. Whatsoever it worked for me pretty well and maybe there is something in you can reuse for EE as well.

http://www.kimmich-digitalmedia.com/videos/001_wpc-installing-wordpress

Cheers

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thanks very much both of you.

Thomas, you might want to link to video 002 rather than 001 as it’s more relevant to this thread.

One gotcha for ExpressionEngine is that the underscore prefix makes your templates hidden as that’s EE’s default indicator for that. A hidden template can’t be used directly from the browser, which may or may not cause you problems. I overwrote that in config with this:

$config[‘hidden_template_indicator’] = ‘hidden_’;


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options