[Pro] rm Command failed

when trying to upload a edited site it fails with the error message saying " rm command failed no such file or directory "
(by edited site pages and pictures have been deleted)
Help need
many thanks
Mike


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

On 19 Nov 2015, at 10:09, ennism wrote:

when trying to upload a edited site it fails with the error message saying " rm command failed no such file or directory "
(by edited site pages and pictures have been deleted)
Help need
many thanks
Mike

‘rm’ is the Unix remove file command. If it’s not there, not being able to delete it isn’t a problem. It just means that the FW on your computer thinks it will be there and asks for it to be deleted.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thanks
But the file it is asking to be deleted has been deleted !


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

On 19 Nov 2015, at 12:42, ennism wrote:

Thanks
But the file it is asking to be deleted has been deleted !

Which is exactly what is required.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Thanks for helping me. -
yes but with file been deleted and the site published again and fails to upload to the server which sends back the error message in full –
"deleting A3 at Speed on LGB Layout’ (file Name)
Cannot delete the file because the server reported an error. - rm command failed;No such file or directory)
with a ref -26042:625:1220


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

At 18:20 +0000 19/11/15, ennism wrote:

Thanks for helping me. -
yes but with file been deleted and the site published again and
fails to upload to the server which sends back the error message in
full –
"deleting A3 at Speed on LGB Layout’ (file Name)
Cannot delete the file because the server reported an error. - rm
command failed;No such file or directory)
with a ref -26042:625:1220

If it happens repeatedly then FW has an incorrect idea of which files
are up there on the live site. Clear out the ‘Site’ folder (or
whatever you’ve called it) where FW puts the html (etc.) files that
it generates on Publish, and then re-Publish to re-populate that
‘Site’ folder (…) with only that which is needed. The Upload then
shouldn’t try to delete any non-existent files.

David


David Ledger - Freelance Unix Sysadmin in the UK.
email@hidden
www.ivdcs.co.uk


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options