[Pro] Submenu hidden behind div with Exhibeo import

I am seeking to sort out this submenu which drops down behind the exhibit import of images.

How can I get the submenu to be to the front in an inline setup? Can this be resolved with the ‘z’ value?

Any helpful comments most welcome.

Many thanks for now

http://www.cyca.org.uk/newsite/ingovanhill.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I am seeking to sort out this submenu which drops down behind the exhibit import of images. How can I get the submenu to be to the front in an inline setup? Can this be resolved with the ‘z’ value?

Crossroads in Govanhill

This is a common problem, and you will have to learn how layering works.

In the code, I can see that you’ve applied the z-index property and value to the element…

#navigation

But the property needs to be applied to…

#navigation.f-ms

The .fms means it is a master page item, so you need to find that item on the master page and change the property there…

z-index: 9999

then make sure the links to the master are preserved on your child pages.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

Hello Ernie,
Many thanks for this.

I have gone into the master page and added the z-index 9999 via the extended option when the navigation item is selected. I am not seeing any change. Is this the correct way to apply the z-index?
I also tried adding the z-index to the navigation container or even the header wrapper to see how that would function but I’m not seeing any change.

Layering is something I’d like to pick up more of an understanding of as such issues emerge quite often.

Let me know where I am going wrong here.

many thanks again.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I’m not going to try and work out where you are going wrong here-- just what is wrong.

Freeway items have Names… Freeway uses these names to make an HTML tag attribute called an ID. If you look at the HTML code, you will see everywhere in the output these

<tag id="name"…

Notice that the id's correspond to the names of things in Freeway… that is not a coincidence.

PS, if you already know this then you’re just wasting my time.

When you look at the CSS code for your page, id values are preceded by the # symbol, as in

#name

and the name of your container with the CSS menu in it is

#navigation

and it does indeed have the z-index property with a high value attached to it. The problem, though, is there is another style in the code

#navigation.f-ms

which is the same item on the master page. It, you can see, has a z-index value of ZERO. This master page style has greater “specificity” a CSS term which just means the browser will ignore all lesser specific forms of that selector are ignored for those properties.

The navigation item is inside of another item, navigation wrapper… you can use the hierarchical list of the page contents window at the left to find the item (on the master page of course).

If you are still unsuccessful, then try writing a more specific version of the style-- that will also solve the problem, albeit in a less orderly manner. The most specific selector for that item would be

div#navigation.f-cf.f-ms

The .f-cf is from the Clearfix action and .f-ms is again a master page item designation. The div at the front just designates the type of item it is.

You can also try adding !important after the z-index value wherever you are adding it. Guaranteed, that is the sloppiest way to fix this.

Best of luck.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options

I had already posted a response to this but it doesn’t appear to be here.

However, I just thought I’d let you know that I resolved this by adding the z-index and value to the div style on the Extended tab for the Css menu, rather than just on the div tab itself. It is possible that I should have been doing this to begin with i.e. adding the z-index to the div style rather than just the div.

It works and I allows me to progress with the many other things to do with this particular project.

Thanks again Ernie for your input.


freewaytalk mailing list
email@hidden
Update your subscriptions at:
https://freewaytalk.softpress.com/person/options