[Pro] URL String No Longer Working

Hi Gang –

I just migrated my site from GoDaddy web hosting to Synthesis web hosting.

Everything is working fine except for the fact that my “normal” URLs don’t function anymore.

For example, I used to be able to send people to this URL and they’d be fine:

But now, that URL doesn’t work unless the .html is added at the end like this:

Does anyone know what might be causing this and how I can fix it?

Thanks,
Jamie


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Your old host had MultiViews turned on, and your new one doesn’t. This takes a minuscule more amount of server processing time per request, so it’s off by default. You can try to turn it on in your site (without waking your service provider) by adding a plain text file to the root of your site folder with just this one line of text in it:

MultiViews on

Once you upload that file to your server, turn on the feature in your FTP application that allows you to see hidden files. If there is already a file in your site folder named .htaccess, then you need to open that and edit it, definitely don’t replace it with a new file that is missing everything else that it already had configured. But if you don’t see a file named .htaccess, rename the text file you uploaded to be exactly .htaccess (leading dot is important). The very next request to your site should now work with or without the file type extension.

The real reason for this feature is so that you can change all your files from .html to .php or whatever else you may want to use, and Apache will serve up the first, best match it can find, even if the file-type extension isn’t the same. (If someone requested products.html, and the only thing in the folder was products.php, the server would send products.php, and not trigger a 404 error.)

Walter

On Nov 20, 2013, at 9:15 PM, Jamie Turner wrote:

Hi Gang –

I just migrated my site from GoDaddy web hosting to Synthesis web hosting.

Everything is working fine except for the fact that my “normal” URLs don’t function anymore.

For example, I used to be able to send people to this URL and they’d be fine:

Marketing Tools, Tips, and Techniques from Leading Experts | Jamie Turner

But now, that URL doesn’t work unless the .html is added at the end like this:

Marketing Tools, Tips, and Techniques from Leading Experts | Jamie Turner

Does anyone know what might be causing this and how I can fix it?

Thanks,
Jamie

http://60secondmarketer.com/83Tools.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Ahhhhh, Walt. I’m so glad you’re part of the community. You always know how to fix things.

I’ll give this a whirl. Thanks!

– Jamie


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options