[Pro] You can have video play in ALL browsers on Mac & PC...

5 days of work and here it is. Thanks Walt (and Dave) for sticking with me… please realize I am an amateur and there may be some things below not done so perfectly.

I was able to get video to play consistently on
MAC, safari, Firefox, Chrome, Opera

PC- windows XP
Chrome, Firefox, Opera, Internet Explorer 8

PC-Windows 7
Chrome, Firefox, Opera, Internet Explorer10

Here is how… I hope this helps anyone!!!

  1. I am using Sublime player action; sign up, get your token #, real easy.

  2. I had to go into my website settings and add MIME types from my website provider and add in
    .ogv
    .webm
    .mp4
    .m4v

and the mime types i.e. video/mp4 etc… I never did this before and was surprised how easy it was and that I did it.

  1. I used HANDBRAKE to change my .wmv files to .m4v files (but before converting I changed the output file name to.mp4 because in Sublime action when you choose your file, it will not let you choose .m4v but does allow .mp4. THis worked fine.
  • I made sure to check WEB OPTIMIZED in handbreak software so when it does play in flash in FF and Opera (i think) it will start right away instead of waiting until fully load)
  1. I used the free program Miro video Converter to change my .mp4 into THEORA/.ogv file and also webm (program works great).

  2. MOST IMPORTANTLY!!! When you set up the sublime player action settings and choosing your files, make sure to choose all 3 of these file types at once (long upload). If you only do 1 then upload, then add another later it won;t work- you must do all 3 at once.

To be honest, I will probably write back tomorrow that none of this works but right now I tested all and seems great.

the only tiny hickup is a weird one…
In Opera for both MAC and PC when I click play for the video nothing kinda happens the first time, but then when I hit the refresh button, it plays. I am not stressing since Opera seems to not be super popular compared to others. It still plays though. I just tried again and it worked the first time I tried.

Once again, I just wanted to write this out for anyone and in case I forget what I did.

I know it sounds like a lot; it was. But hopefully worth it.

Barry


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

adding,

tested on iPhone. Perfect play. I do not have an ipad so will confirm soon.
Barry


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

slight update…

video at school on Internet Explorer 8 plays, but music is lagging behind the video (not good). SInce it is a slideshow it is “off” by about 1 second or so. I tried on mutliple machines. They have Dell with WIndows XP.

On my mac (windows side) in Internet Explorer 8 it plays the same (bad way).


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Can we see the example?

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

sure- would like to know how it goes for people.

The link below will change in some weeks as this is temp URL

http://hoffkids.com/FWtest/sublime2001-2002.html

would love to know why I have to hit refresh in opera to work?
i just hit play (nothing), then refresh, plays right away.

Thanks for any feedback if it works for you or not.

Barry


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options