Read More placement

I’m working on my gallery web site. Under each painting image is 3 centred caption lines and I have placed the “read more” action at the end of last line.
The more action which is in some kind of container box appears to occupy about 13 characters so offsets the centred caption text accordingly.
However when published and previewed with the browser, the more is actually on it’s own line underneath and left aligned. I’d rather it stay where it was but the new line is OK.
Problem is the last line of the caption remains off centred and looks bad.
Putting the read more totally on it’s own line avoids the centre problem but creates too much empty vertical space.
Anyone know how to fix this?
Thanks so much. Barry


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Anyone know how to fix this?

I’m afraid not! But chances increase by a shared link to the example.

Cheers

Thomas


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Thomas,
Thanks for feedback.
I’m weeks away from being able to put anything up to an actual web site so I don’t have any links as such.
But now that you’ve planted the seed, I’ll see what I can do.
cheers Barry


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Problem is the last line of the caption remains off centred and looks bad. Putting the read more totally on it’s own line avoids the centre problem but creates too much empty vertical space. Anyone know how to fix this?

I have spent some time on this to find a solution.

If you want the last line of text centre aligned then you need to select the Read More action item on the FW page and set its width to 1px - FW will not allow you to make it 0.

If you then want the ‘more…’ text to be centre aligned then you will need to add this your Page>html Markup in the before end head slot using the following:

.more {
	text-align: center;
	}

You can also add other styling options in there such as

.more {
	cursor: pointer;
	color: white;
	background-color: black;
	text-align: center;
	}

There are of course other ways to create styles - this is just one of many.

I wont bore/confuse you with the details of why this happens but it is to do with spans etc.

It is possible that tweaks to the Action code could avoid this but it is probably not a common enough use case to warrant it.

David


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

I forgot the example link - http://deltadesign.co/FW7Test//read-more-example.html


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Thanks Dave
That sounds like you have the fix! I will try it as soon as I get home.
Cheers Barry


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

Dave you are scoring 10 for 10!
Yes changing the width to 1 is a great work around and fixed the problem.
I wonder if the one pixel width could be “preset” for the read more action as I will be needing to apply it almost 300 times!
No big deal though as at least it can be tamed now.
Thank you!
Barry (from west coast Canada)


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options

You could apply a class to the Read More action item and then hard code the CSS with the width. That way you could just Copy/Paste the RM action item into each instance. But you can do that anyway without an added class - just resize it first.

D


freewaytalk mailing list
email@hidden
Update your subscriptions at:
http://freewaytalk.net/person/options