XWay wont save document?

I’ve been working on an Xway site and suddenly getting the message “The document xx.xway could not be autosaved. The file name is invalid. Your changes will not be saved until the problem is resolved” I’ve tried changing the document name, tried “saving as” but it just wont save… I hate to loose hours of work! Any suggestions?

Hi Seth,

This is a system alert. I’ve never seen it happen with Xway, but I found a thread where people discuss having this problem with TextEdit. Do any of their suggestions sound relevant? Have you pasted any images?



I’ve not pasted any images, I did add some PDF’s as resources, though none of them had unusual names, I’ve now tried deleting all those that I added along with the links to them but still getting the same error message…. I tried reverting back to a previous version from yesterday and still the same message….also have tried the obvious quitting the app and rebooting to no avail….

Fixed! I ended up trashing the document.plist from within the package, upon reopening, Xway couldn’t find the file but after I pointed to it and opened it I was then able to save as normal. Yay!

That’s pretty drastic - the document.plist file contains all the data that is in your document (apart from the Resources and Site folders).

But Xway will have recreated this when you saved, so hopefully you’re OK.

If anything like this happens again, I’d suggest duplicating the document (in the Finder) and sending us a copy if it’s a reproducible problem.