Problem running Freeway through Parallels Desktop

I am currently running macOS Mojave 10.14.6 and have recently installed Parallels Desktop 17 specifically to be able to continue using Freeway Pro 7.1.4 to service my website. After copying the relevant application files and folders to Parallels Desktop I successfully succeeded in updating my website in Freeway and uploading it to the internet. However, the next time I tried to make changes to the website I was unable to ‘Preview in browser’, with the following error message: Program error (-26100:251:1404). To try to solve the problem I deleted the Freeway application and website file and reinstalled them on Parallels Desktop. Everything worked the next time I made changes and uploaded the updated website, but the second time I tried to make changes (the next day) I was presented with the same error message. I have a very large website that I update frequently, often on a daily basis, so I would appreciate any help in solving this problem.

Hi Rob,

The error number suggests that this is some kind of graphic problem. The first thing that you could try would be to open the Edit Resources dialog and choose Resample All.

Hi Jeremy,

Thanks for your message. I have tried Resampling All Resources as you suggest, but the problem still remains with the same error message.

Kind regards,


You could try narrowing the problem down to see if it is related to a specific page or graphic.

  1. Narrowing down to a specific page: start at the first page in your document and switch to the Preview tab at the top of the window. If that works, go back to the Page tab, switch to the next page (via the Site panel or Next Page in the View menu) and switch again to the Preview tab. Keep doing this until the error message is displayed. Switching to the Preview tab publishes just the current page.

  2. Narrowing down to a specific graphic: display the Edit Resources graphic and turn off the Publish checkbox for half the resources, then publish the document. If you see an error message, turn off the Publish checkbox for half the remaining resources and republish. If you don’t see an error message, turn the Publish checkbox back on for the resources that you (most recently) turned it off for. Keep going till you find a specific graphic that is causing the problem.

One other thing to bear in mind is that Freeway has problems if the file size of a document is greater than 2 GB. What size is your document?


I look forward to reading your reply to Jeremy, Rob. I’m still on High Sierra ONLY because I want to keep updating my Freeway 7 Pro websites. People have been advising me to “just use Parallels,” but sure enough I come across your post today. By sticking with High Sierra, I avoid Freeway related trouble, but I am also having other trouble with newer apps that require Mojave or higher!

Have you tried Mojave? The real trouble doesn’t start until Catalina, in my experience. Mojave is the last version that accepts 32-bit apps. Catalina shuts that door, even for 64-bit apps that have some 32-bit library calls, like Apple’s own Aperture. I keep one Mac “pinned” to Mojave just for Aperture, since nothing else replaces it (for me–entirely subjective).


Hi Jeremy,

For a short while I thought we might have cracked it. I followed your advice and tried to track down the problem through Edit Resources. I found quite a few graphics that were listed as Missing or Detached and spent several hours reinstalling them. But the end result was still the same. I could edit my website in the home partition and copy it into the Parallels Desktop partition, at which point I could Preview each page, Preview in browser and upload the site. However, as soon as I made a single change to any of the pages the Program Error message appeared.

My website is a catalogue/discography of Studio One albums. There are currently 287 pages that are all graphics heavy. The size of the document is 277MB, which is well short of the 2GB you suggest might be problematic. Interestingly, when I upload the site in the home partition the progress window counts down from 2716 items, whereas when I upload from the Parallels partition it counts down from 4065 items. I have also noticed that whenever I upload from Parallels I am prompted to change the FTP setting from Non-Passive to Passive before I can continue.

I am working from a trial version of Parallels Desktop in the hope that the program will allow me to continue to service my website from macOS Mojave while updating my home partition to later OS systems. The trial runs out at the end of this week…

I could edit my website in the home partition and copy it into the Parallels Desktop partition

Is this a native Parallels volume or a shared volume (one that you can access from Parallels and from your main system)?

However, as soon as I made a single change to any of the pages the Program Error message appeared.

Does this message appear for every page that you preview within Freeway (by clicking on the Preview tab at the top of the window)?

“Is this a native Parallels volume or a shared volume (one that you can access from Parallels and from your main system)?”

It’s a shared volume.

“Does this message appear for every page that you preview within Freeway (by clicking on the Preview tab at the top of the window)?”


I myself haven’t tried Mojave. My son’s computer has been on High Sierra for a long time, so I recently upgraded him to Catalina. He hated it because many of his games died, so I downgraded him to Mojave. He said he has some problems versus High Sierra but it’s acceptable. I’ve stayed on High Sierra because it’s rock solid and offers me no trouble whatsoever. It’s just that some newer apps require Mojave or later, which is annoying.

Rob Chapman, it seems like you’ve used Freeway on Mojave (not Parallels) without problems, is that correct?

Try putting the document on a native volume. Other people who use Freeway with Parallels have reported problems when using a shared volume.

What is the difference between a shared and a native volume? I have Parallels in a separate ‘partition’ that I can open on top of the home system. This allows me to drag and drop items from the home to Parallels (and vice versa). Should I be running Parallels from an external disk?

Hi James,

I have been running Freeway on Mojave without any problems, but maybe I should try running Parallels in High Sierra instead. However, I’m not sure how I would be able to install High Sierra in Parallels to replace Mojave.

Hi Rob,

I don’t have Parallels - it’s of limited use with M1 Macs - but I think that a shared volume is a folder (within your main system) that appears as a server volume within your Parallels system. You can use this to transfer files between the two systems, but it may cause you problems if you edit files that are on a shared volume.

You don’t need to run Parallels from an external disk, but I think you should try copying your Freeway document to a volume that exists within the Parallels system (not a shared volume). You may also need to copy the document’s resources.

Hi Jeremy,

Thanks for your reply. I have been copying my Freeway document, together with all resources, to a folder within Parallels. From here I can open it, preview each page, preview in browser and upload the file. However, if I make any changes to the document I get the error message as soon as I try to preview or upload.

I have spent this morning trying to download a copy of macOS High Sierra, in the hope that running this in Parallels instead of macOS Mojave might solve the problem. I did (eventually) find a way to download Sierra, but unfortunately I can’t find a way of getting Parallels to recognize Sierra.

It looks like I am going to have give up with Parallels when the trial runs out this week, and maybe try to find another program that will provide a Virtual Machine that will allow me to continue running Freeway in Mojave.

If you create a cut-down document with just a few pages and resources, does the problem still happen?

Is this partition accessible to the host system while you are running Mojave in Parallels? This arrangement where both systems have access to the filesystem can cause issues with file access in some circumstances.

The way I have it set up is by using a virtual hard disk (I believe this is the default when creating a virtual machine in Parallels) and then creating a shared folder (macOS network share, not a Parallels share) which I can then connect to from the host system as if I’m connecting to any other machine in the network.

I’ve not had any issues with Mojave set up like that with Parallels 16 running on Catalina or Big Sur. I would recommend reinstalling Mojave in a new VM using a virtual hard disk instead of a real partition. If the problem persists with it set up like that, it may not be related to Parallels but rather a general problem.

Yes, same problem. I created a new document with just 4 items, graphics and HTML.

If you send us a copy of your cut-down document (and resources), Simon can test it under his system. The best way to send it is to put a zipped copy on a file sharing service (Dropbox, WeTransfer etc.) and send a link to support at softpress dot com.

I have sent a folder via WeTransfer. Let me know if it arrives OK, or if you need me to send it another way.